WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 2 years ago

#17952 closed task (blessed) (fixed)

Update to latest jQuery and UI

Reported by: hebbet Owned by: azaozz
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.2
Component: External Libraries Keywords: needs-patch
Focuses: Cc:

Description

Attachments (1)

17952.patch (179.2 KB) - added by ocean90 3 years ago.

Download all attachments as: .zip

Change History (29)

comment:1 ramoonus3 years ago

  • Cc ramoonus@… added

comment:2 ramoonus3 years ago

maybe for 3.2.1

comment:3 nacin3 years ago

  • Keywords 3.3-early added
  • Milestone changed from Awaiting Review to Future Release

We'll drop this into trunk right after we branch. If things don't break then 3.2.1 is possible.

ocean903 years ago

comment:4 ocean903 years ago

  • Keywords has-patch added; needs-patch removed

comment:5 ryan3 years ago

  • Milestone changed from Future Release to 3.3

comment:6 follow-up: azaozz3 years ago

  • Keywords 3.3-early has-patch removed
  • Owner set to azaozz
  • Status changed from new to reviewing
  • Summary changed from Update to jQuery 1.6.2 to Update to latest jQuery and UI

The update to jQuery 1.6.1 brought quite a few plugin/theme issues despite that we did everything possible to warn plugin and theme authors. Perhaps we should update both jQuery and UI in August and stick with them for 3.3.

comment:7 hebbet3 years ago

related: #17474

comment:8 follow-up: azaozz3 years ago

Closed #17474 as duplicate.

Replying to jczorkmid:

For compatibility's sake this is a good idea. Was hoping we would move away from UI in core as we mostly use it for drag+drop support and there are lighter jQuery plugins for this.

However it seems many WordPress plugins and themes will continue to use UI, so adding the whole UI to core will make it easier for them. The only "against" would be the increase of the total download size of WP.

On the other hand we probably could un-bundle Prototype.js as very few plugins seem to use it. Perhaps we can leave it in script-loader but load it from Google.

Version 0, edited 3 years ago by azaozz (next)

comment:9 in reply to: ↑ 6 ramoonus3 years ago

Replying to azaozz:

The update to jQuery 1.6.1 brought quite a few plugin/theme issues despite that we did everything possible to warn plugin and theme authors. Perhaps we should update both jQuery and UI in August and stick with them for 3.3.

true but was 1.6.1 or 1.6 to blaim?
i think 1.6

comment:10 in reply to: ↑ 8 ; follow-up: jczorkmid3 years ago

  • Cc jpenney@… added

Replying to azaozz:

Closed #17474 as duplicate.

Should I attach the jQuery UI patch to this ticket so it doesn't get lost in the shuffle?

comment:11 in reply to: ↑ 10 azaozz3 years ago

Replying to jczorkmid:

No need, whoever commits this can grab the latest version from the UI website if there's one or use the patch from #17474.

comment:12 follow-up: jczorkmid3 years ago

Ok, thanks. Hopefully they won't just grab the latest. The patch also added the remainder of the UI libraries to wp-includes/script-loader.php. :)

Last edited 3 years ago by jczorkmid (previous) (diff)

comment:13 in reply to: ↑ 12 ramoonus3 years ago

errrrrrrr

Last edited 3 years ago by ramoonus (previous) (diff)

comment:16 ramoonus3 years ago

  • Keywords needs-patch added

jQuery 1.6.3 ...

comment:17 follow-up: marcelometal3 years ago

I updated WP for use jQueryUI >= 1.8.13 and an error occurred when using a new widget in the sidebar.

In wp-admin/js/widgets.js, line 113:

var add = ui.item.find('input.add_new').val(),
    n = ui.item.find('input.multi_number').val(),
    id = ui.item.attr('id'),
    sb = $(this).attr('id');

'id' is undefined, because it was removed from ui.item

http://bugs.jqueryui.com/ticket/4564

https://github.com/jquery/jquery-ui/commit/98fcb477d6a7091b21e9b7bc0b8c28f798954d47#ui/jquery.ui.draggable.js

comment:18 in reply to: ↑ 17 azaozz3 years ago

Replying to marcelometal:

Yes, this is a regression. Still wondering what's better: patch that and update to 1.8.16 or keep 1.8.12. Opened a ticket on UI's trac: http://bugs.jqueryui.com/ticket/7734

comment:19 follow-up: nacin3 years ago

Would rather patch and update to 1.8.16, but still track this upstream. Thanks for submitting.

comment:20 azaozz3 years ago

In [18757]:

Update jQuery to 1.6.4, update jQuery UI to 1.8.16, add the rest of UI, add workaround for a regression in UI Draggable, see #17952

comment:21 in reply to: ↑ 19 azaozz3 years ago

Replying to nacin:

Yes, added a workaround for that, preferable to changing it. Hopefully it will not break anything else as combining Draggable with a Sortable is not common.

comment:22 Viper007Bond3 years ago

Glad to see the full jQuery UI library rolled in.

comment:23 follow-up: azaozz3 years ago

In [18774]:

Fix the workaround for UI Draggable to include single instance widgets (do they still exist?), see #17952

comment:24 in reply to: ↑ 23 nacin3 years ago

Replying to azaozz:
single instance widgets (do they still exist?)

They're all over the place, for sure.

Akismet even still uses them.

comment:25 nacin3 years ago

In [18795]:

Correct the src for jquery-ui-datepicker. props danielbachhuber, fixes #18793. see #17952.

comment:26 ryan3 years ago

  • Type changed from enhancement to task (blessed)

comment:27 ryan3 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

Resolving as fixed. We can open a new ticket if and when the jui regression is addressed upstream.

comment:28 Anton Torvald2 years ago

Nothing.

Last edited 2 years ago by ocean90 (previous) (diff)
Note: See TracTickets for help on using tickets.