WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17984 closed defect (bug) (duplicate)

Widget-ID breaks Widget page

Reported by: bembelimen Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Widgets Keywords:
Focuses: Cc:

Description

If you create a widget called "footer" and open wp-admin/widgets.php the widget-dropdown on the right hand is broken.

Defect: The div where you can drag&drop the different widget has an ID which is equal to the widget name (for example "footer"). But #footer is also used by the admin theme itself, so some unexpected css declaration will influence the div and a "footer" will be placed at the bottom of the page.

Solutions: remove the ID from the div or add a prefix

Attachments (1)

patches.zip (800 bytes) - added by bembelimen 6 years ago.
Two alternative solutions as patch files

Download all attachments as: .zip

Change History (3)

@bembelimen
6 years ago

Two alternative solutions as patch files

#1 @andrewryno
6 years ago

  • Keywords widget id css removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14466.

#2 @kawauso
6 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.