WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 22 months ago

Last modified 21 months ago

#17992 closed defect (bug) (fixed)

Wrong Tooltip in the Editor

Reported by: simsmaster Owned by: azaozz
Milestone: 3.5 Priority: normal
Severity: minor Version: 3.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

In the new Fullschreen-Editor, the Upload/Insert Media Button has, referring to the Tooltip, the Shortcut Alt+Shift+M.
When I press this Combo, the wrong Dialog opens.

I'm not sure, if the Tooltip is wrong or the Shortcut wrongly assigned...

Attachments (3)

add media.JPG (67.5 KB) - added by saltcod 3 years ago.
17992.diff (1.1 KB) - added by solarissmoke 3 years ago.
Fix add image button in DFW
17992.both-dialogs.png (123.2 KB) - added by SergeyBiryukov 3 years ago.
Screenshot of both dialogs at the same time

Download all attachments as: .zip

Change History (19)

saltcod3 years ago

comment:1 saltcod3 years ago

Don't know that I've ever seen that dialog box before.

comment:2 SergeyBiryukov3 years ago

In trunk, "Insert/edit image" button doesn't seem to work at all in DFW.

comment:3 Ipstenu3 years ago

+1 to Sergey - Doesn't work on WordPress 3.3-aortic-dissection-r18665.

solarissmoke3 years ago

Fix add image button in DFW

comment:4 follow-up: solarissmoke3 years ago

  • Keywords has-patch dev-feedback added

The button wasn't working because the IDs have changed on the main editor buttons (not sure why, maybe a change in TinyMCE), which the DFW button Javascript was using. Patch fixes that.

Regarding Alt+Shift+M, even in normal editing mode that produces a different dialog box to what the add/image button does. I'm not sure what the original intention was, but it seems we should remove that from the tooltip at least, seeing as the button doesn't do the same thing?

comment:5 SergeyBiryukov3 years ago

  • Milestone changed from Awaiting Review to 3.3

Related: #17144

comment:6 in reply to: ↑ 4 azaozz3 years ago

Replying to solarissmoke:

The button wasn't working because the IDs have changed on the main editor buttons

Meant to fix this on #17144, it's broken as the editor together with all links/buttons around it supports multiple instances now.

Regarding Alt+Shift+M, even in normal editing mode that produces a different dialog box to what the add/image button does.

The shortcuts in TinyMCE execute internal commands. Will change this one to open the new Link popup.

comment:7 azaozz3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [18710]:

Add TinyMCE command to handle opening of the upload/insert popup, fix the shortcut "Alt+Shift+M", fix the "image" button in DFW, fixes #17992, fixes #18697, see $17144

comment:8 follow-up: SergeyBiryukov3 years ago

  • Keywords has-patch removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

In trunk, pressing Alt+Shift+M shows inconsistent behaviour in different browsers:

  • Firefox 6 & 7 — Visual/DFW mode: thickbox + quicktags dialog; HTML mode: nothing
  • Chrome 14, IE 8 — Visual/DFW mode: thickbox dialog; HTML mode: quicktags dialog
  • Opera 11 — Visual/DFW mode: thickbox dialog; HTML mode: nothing

One of the options would probably be to remove the quicktags img dialog shortcut.

comment:9 in reply to: ↑ 8 azaozz3 years ago

Replying to SergeyBiryukov:

Think I fixed some or all of these in a different ticket. Could you re-test it again, seem fine here.

comment:10 follow-up: SergeyBiryukov3 years ago

Updated to r18803, cleared the cache. Still the same. Here are some steps to reproduce:

In Firefox 7:

  1. Switch to HTML tab.
  2. Press Alt+Shift+M. quicktags dialog won't open.
  3. Switch to Visual tab.
  4. Press Alt+Shift+M. Both thickbox and quicktags dialog will be opened at the same time.

In Opera 11.51, quicktags dialog won't open in step 2. thickbox in step 4 is fine.

In Chrome 14 and IE 8, both dialogs are fine.

SergeyBiryukov3 years ago

Screenshot of both dialogs at the same time

comment:11 in reply to: ↑ 10 azaozz3 years ago

Replying to SergeyBiryukov:

In Firefox 7:

  1. Switch to HTML tab.
  2. Press Alt+Shift+M. quicktags dialog won't open.
  3. Switch to Visual tab.
  4. Press Alt+Shift+M. Both thickbox and quicktags dialog will be opened at the same time.

The problem with FF is that it uses Alt+Shift+[letter] to activate the accesskey attribute for links and buttons and it doesn't seem to be able to cancel it. On top of that it doesn't trigger properly the click event when executing the accesskeys, so instead of opening the dialog it highlights the button and the user has to press Enter to "execute" it.

Surprisingly all the accesskeys are triggered when the HTML editor is hidden...

I'm not sure we can do much from JS to fix this behavior (it doesn't trigger any of the other buttons too). We could remove all the accesskey attributes when in FF since they trigger errors when the HTML editor is hidden. The other option would be to load another JS that assigns new/different keys in Quicktags in FF.

comment:12 azaozz2 years ago

  • Milestone changed from 3.3 to Future Release

Not a regression, affects only FF, moving to 3.4.

comment:14 azaozz22 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In [21266]:

TinyMCE: update the keyboard shortcuts: Alt + letter for Firefox and WebKit, Alt + Shift + letter for IE and Opera, add shortcut for DFW (Alt + W), see #21214, fixes #21197, fixes #17992

comment:15 azaozz22 months ago

  • Keywords dev-feedback removed
  • Milestone changed from Future Release to 3.5
Note: See TracTickets for help on using tickets.