WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 months ago

Last modified 7 months ago

#17999 closed defect (bug) (duplicate)

Failure to Update Notification Persists After Manual Upgrade

Reported by: Lorelle Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Upgrade/Install Keywords: needs-patch
Focuses: Cc:

Description

This has been around for a few versions. When an update fails, if the user updates or upgrades manually and WordPress lists the updated version in the Administration Panels, the failure to update notification persists.

I've sat through four or five updates with the failure notice on every panel, including WordPress 3.2, on several sites.

Change History (8)

comment:1 nacin3 years ago

This is by design.

.maintenance will stick around after a failed automatic update. It needs to be removed as part of the manual update steps.

It might be a good idea to change .maintenance to a non-hidden file so it would be easier to delete, but that's about it.

comment:2 Lorelle3 years ago

Really? Instructions need to be in place on how to remove this as part of the manual update. Are there such instructions? Thanks.

comment:4 Lorelle3 years ago

Ah, hadn't noticed that page had been updated.

Still doesn't discount the fact that "I" think this part should be automatic. :D

Thanks,

Lorelle

comment:5 follow-up: nacin3 years ago

I think we can automate this a little.

We could store the WP version we're trying to get to in .maintenance, then compare it to $wp_version. If they match, then we could probably assume the update was successful.

MD5 verifications of updates (3.3?) would be another nice touch.

comment:6 in reply to: ↑ 5 SergeyBiryukov15 months ago

Replying to nacin:

MD5 verifications of updates (3.3?) would be another nice touch.

Related: #20074

comment:7 dd327 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #14028.

comment:8 helen7 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.