WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 13 months ago

#18024 closed defect (bug) (fixed)

Twenty Eleven Showcase template fails on IE7 and IE8

Reported by: Gecka Owned by: lancewillett
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.2
Component: Bundled Theme Keywords: has-patch commit
Focuses: Cc:

Description

The showcase template is incompatible with IE7 (wrong sticky post thumbnail size and alignement) and IE8 (the sticky posts thumbnails do not appear)

Attachments (4)

Skjermbilde 2011-07-30 kl. 23.57.37.png (163.7 KB) - added by peterhol 3 years ago.
ie8 screen shot
Skjermbilde 2011-07-30 kl. 23.58.39.jpg (214.0 KB) - added by peterhol 3 years ago.
ie8 compat mode screen shot
diff.txt (1.0 KB) - added by peterhol 3 years ago.
Ok, I got the featured posts to show in ie8, and fixed the positioning problem in ie7. through css. seems the <section>s needed some size definitions, and the positioning for ie7 seems to have been wrong..
18024.diff (839 bytes) - added by obenland 14 months ago.

Download all attachments as: .zip

Change History (14)

comment:1 ocean903 years ago

  • Component changed from Themes to Bundled Theme
  • Keywords dev-feedback removed
  • Severity changed from blocker to normal

Some screenshots would be nice.

peterhol3 years ago

ie8 screen shot

peterhol3 years ago

ie8 compat mode screen shot

comment:2 peterhol3 years ago

  • Cc peterhol added

I can confirm this bug… at least from here.. see screen shots :)

comment:3 peterhol3 years ago

Some info regarding IE9's "document modes for IE8/7 testing":

Be careful relying on IE9's document modes for IE8/7 testing. Check out the Additional Information section of the article - http://officialtechnews.net/email/ie9%E2%80%99s-document-modes-and-javascript.html. The js engine is not perfectly consistent with that of the earlier versions.

Guess this might explain why testing for IE compatibility is problematic...

peterhol3 years ago

Ok, I got the featured posts to show in ie8, and fixed the positioning problem in ie7. through css. seems the <section>s needed some size definitions, and the positioning for ie7 seems to have been wrong..

comment:4 peterhol3 years ago

a comment though: I'm running IE8 on a virtual machine on my mac. Don't know if that's the reason, but the script is pretty unstable in ie8... when running through the images, they sometimes show and sometimes they don't (but they might show if you wait a bit, or click the frame where the image should have been..

comment:5 peterhol3 years ago

  • Keywords has-patch added; needs-patch removed

comment:6 nacin2 years ago

  • Owner set to iandstewart
  • Status changed from new to assigned

comment:7 lancewillett17 months ago

  • Keywords early added
  • Milestone changed from Awaiting Review to Future Release
  • Owner iandstewart deleted

Early 3.6 this needs a refresh and commit.

comment:8 lancewillett14 months ago

  • Keywords needs-refresh added; early removed
  • Milestone changed from Future Release to 3.6

obenland14 months ago

comment:9 obenland14 months ago

  • Keywords commit added; needs-refresh removed

Updated patch. Tested in IE7/8 mode in Win7.

comment:10 lancewillett13 months ago

  • Owner set to lancewillett
  • Resolution set to fixed
  • Status changed from assigned to closed

In 23647:

Twenty Eleven: fix showcase template display in IE7 and IE8, props obenland. Fixes #18024.

Note: See TracTickets for help on using tickets.