WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18029 closed defect (bug) (fixed)

Collapse menu in RTL mode

Reported by: ramiy Owned by: yoavf
Milestone: 3.2.1 Priority: normal
Severity: normal Version: 3.2
Component: RTL Keywords: has-patch
Focuses: Cc:

Description

When collapsing the side menu on wordpress dashboard, the content area should become wider.

It's not working on RTL dashboards, the content area is not getting wider.

Attachments (2)

18029.diff (372 bytes) - added by rosshanney 3 years ago.
18029.2.diff (352 bytes) - added by rosshanney 3 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 nacin3 years ago

  • Milestone changed from Awaiting Review to 3.2.1

comment:2 ramiy3 years ago

  • Summary changed from Collapse menu in RTL more to Collapse menu in RTL mode

rosshanney3 years ago

comment:3 rosshanney3 years ago

  • Keywords has-patch added; needs-patch removed

rosshanney3 years ago

comment:4 rosshanney3 years ago

I believe new patch is sufficient, as admin menu cannot be collapsed without JavaScript.

comment:5 ramiy3 years ago

patch tested, not working.

comment:6 rosshanney3 years ago

Are you sure? It seems to do the trick for me. Do you have SCRIPT_DEBUG enabled (the patch is for global-rtl.dev.css, not global-rtl.css)?

comment:7 ramiy3 years ago

i tested the patch again (18029.2.diff - global-rtl.dev.css) in a different site. still not working.

comment:8 nacin3 years ago

Patch works for me. The issue is that we need to properly override the CSS changes that went into [18349].

comment:9 nacin3 years ago

In [18420]:

Fix RTL admin menu collapsing margin. props rosshanney, see #18029 for trunk.

comment:10 nacin3 years ago

In [18421]:

Fix RTL admin menu collapsing margin. props rosshanney, see #18029 for 3.2.

comment:11 nacin3 years ago

  • Severity changed from major to normal

Leaving open for final review by azaozz. Some other things in global-rtl.css might deserve some edits.

comment:12 azaozz3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In [18428]:

Fix expanding the admin menu in RTL mode when no JS and collapsing it when JS, fixes #18029 for trunk

comment:13 azaozz3 years ago

In [18429]:

Fix expanding the admin menu in RTL mode when no JS and collapsing it when JS, fixes #18029 for 3.2

comment:14 SergeyBiryukov3 years ago

  • Keywords rtl-feedback removed
Note: See TracTickets for help on using tickets.