WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#18055 closed defect (bug) (invalid)

Wordpress 3.2 - images in post with left/right alignment won't allow text next to them

Reported by: darcym Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: Formatting Keywords: close reporter-feedback
Focuses: Cc:
PR Number:

Description

I have been running a personal blog on wordpress 2 platform upgrading with each new release as they come out.

in previous versions of wordpress, if I inserted a picture into a post and aligned it to the left/right with the wordpress "new post" interface, I could put text next to the image.
An example of this would be

http://www.matthewdarcy.co.uk/2010/07/site-updates-recording-reading-ba003/

or

http://www.matthewdarcy.co.uk/2011/01/ba002-finished/

after an upgrade to wordpress 3.2 - this behaviour has changed.
the interface will randomly allow me/not allow me to put text next to aligned pictures.

an example post would be

http://www.matthewdarcy.co.uk/2011/07/amps-updates/

in this example, I put a picture in aligned it left and typed, the text went along side the picture and then across the bottom of the picture as expected, I put another picture in and aligned it to the right, however the cursor in the new post interface will not go to the left of the image, and if I type above the image it just pushes the image down a line with each new line.

I have tried changing the alignment of this picture to the right and trying to get the text to go to the right, it will not happen. This behaviour has only appeared since upgrading to Wordpress 3.2

I am running wordpress 3.2 on Centos 5.6 64 bit with Apache 2.2.3

Change History (9)

#1 @sterlo
8 years ago

I don't seem to be able to reproduce this at all.

According to the example that you gave - the reason its not floating as expected is because you're floating it after the content and not before.

#2 @nacin
8 years ago

  • Milestone changed from Awaiting Review to 3.2.1

This isn't the first bug report I've seen related to this.

#3 follow-up: @azaozz
8 years ago

  • Keywords close added

Works properly for me too. Even tried changing alignment and pasting some text on the page you referenced and it worked as expected. Perhaps the alignment in the editor is affected by your theme's editor-style.css.

#4 in reply to: ↑ 3 @jkudish
8 years ago

Replying to azaozz:

Works properly for me too. Even tried changing alignment and pasting some text on the page you referenced and it worked as expected. Perhaps the alignment in the editor is affected by your theme's editor-style.css.

agreed, I would think this is a theme specific issue

#5 @kawauso
8 years ago

I wouldn't put it past TinyMCE to be breaking in odd ways, happens often enough in my experience.

#6 @nacin
8 years ago

  • Keywords reporter-feedback added

#7 @azaozz
8 years ago

  • Milestone changed from 3.2.1 to Future Release

Waiting for reporter feedback.

#8 @nacin
8 years ago

  • Milestone changed from Future Release to Awaiting Review

#9 @azaozz
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

No reporter feedback in 2 months, perhaps the problem was caused by something else.

Note: See TracTickets for help on using tickets.