WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18059 closed defect (bug) (invalid)

Wordpress 3.2 > Select All > Update Plugins Problem

Reported by: espressive Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: UI Keywords: reporter-feedback
Focuses: Cc:

Description

HI there,

On the update page in Wordpress 3.2, wp-admin/update-core.php?action=do-plugin-upgrade, the select all toggle does not tick all plugin boxes.

Change History (12)

comment:1 duck_3 years ago

  • Keywords reporter-feedback added

Cannot reproduce. What browser and OS? Have you tried disabling all plugins and using the default theme?

comment:2 follow-up: espressive3 years ago

Sorry mean to include that info. Ubuntu 11.04 using Chrome 12. Will try disabling plugins, using the default admin theme.

comment:3 in reply to: ↑ 2 duck_3 years ago

Replying to espressive:

Sorry mean to include that info. Ubuntu 11.04 using Chrome 12. Will try disabling plugins, using the default admin theme.

Same setup as myself then. I meant the theme used for the frontend of your site and not grey/blue admin theme.

comment:4 toscho3 years ago

  • Cc info@… added

Confirmed.
Single site installation with a simple theme without backend options.

comment:5 nacin3 years ago

Check For JavaScript errors. Disable all plugins and switch to the default theme.

comment:6 espressive3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Bug fixed in 3.2.1 update, thanks!

comment:7 dd323 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 dd323 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

There were no changes made related to that code AFAIK, and I couldnt reproduce either.

comment:9 follow-up: toscho3 years ago

  • Cc info@… removed
  • Resolution worksforme deleted
  • Status changed from closed to reopened

I still have the problem. Here is the output from Opera’s error console:

Uncaught exception: TypeError: 'a(this).prop' is not a function

Error thrown at line 1, column 10318 in <anonymous function>(l) in http://toscho.de/wp-admin/js/common.js?ver=20110610:
    var m=a(this).prop("checked"),k="undefined"==typeof toggleWithKeyboard?false:toggleWithKeyboard,j=l.shiftKey||k;
called from line 55, column 294 in <anonymous function: handle>(a) in http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js:
    i=i.handler.apply(this,arguments);
called via Function.prototype.apply() from line 49, column 569 in <anonymous function: o>() in http://ajax.googleapis.com/ajax/libs/jquery/1.4.2/jquery.min.js:
    return typeof c!=="undefined"&&!c.event.triggered?c.event.handle.apply(o.elem,arguments):w

On some other sites it works.

Version 0, edited 3 years ago by toscho (next)

comment:10 toscho3 years ago

  • Cc info@… added

comment:11 in reply to: ↑ 9 duck_3 years ago

Replying to toscho:

I still have the problem.

Try disabling all plugins and switch to the default theme.

The error message is showing the use of jQuery served from the Google CDN which is not default behaviour. The problem is probably the usage of the old jQuery 1.4.2 and I would guess the culprit is your theme.

comment:12 toscho3 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Ah, right. I used the plugin »Use Google Libraries« which is outdated. Closing this as invalid.

Note: See TracTickets for help on using tickets.