WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18063 closed defect (bug) (worksforme)

When viewing category view an error is thrown

Reported by: garyjob Owned by: Gary Teh
Milestone: Priority: normal
Severity: trivial Version: 3.1.4
Component: Query Keywords:
Focuses: Cc:

Description (last modified by dd32)

This is the error


[Mon Jul 11 00:04:56 2011] [error] [client 127.0.0.1] PHP Warning: reset() [<a href='function.reset'>function.reset</a>]: Passed variable is not an array or object in C:\\applications\\nubee\\htdocs\\wp-includes\\query.php on line 2891, referer: http://wordpress_site/?category_name=game-zh-hans&lang=zh-hans&lang=zh-hans

This is the proposed fix:

if(isset($query['terms'] )){
	$term = get_term_by( $query['field'], reset( $query['terms'] ), $query['taxonomy'] );
}
else{
	$term = get_term_by( $query['field'], $query['terms'] , $query['taxonomy'] );				
}

Change History (3)

comment:1 scribu3 years ago

  • Description modified (diff)

comment:2 dd323 years ago

  • Description modified (diff)

How can we reproduce this warning? (I can't)

Can you reproduce it with all plugins disabled and the default theme active?

Last edited 3 years ago by dd32 (previous) (diff)

comment:3 SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce either.

Feel free to reopen with more information if there's still a problem.

Note: See TracTickets for help on using tickets.