WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 10 years ago

#18099 closed defect (bug) (worksforme)

cron error with ALTERNATE_WP_CRON set to true

Reported by: luis.ferro Owned by:
Milestone: Priority: normal
Severity: blocker Version: 3.2
Component: Cron API Keywords:
Focuses: Cc:

Description

If you turn on ALTERNATE_WP_CRON on a stock WP 3.2.1 you will get an error of undefined function wp_redirect() in cron.php.

This is due to the order of includes in wp-settings.php which is wrong in this use-case.

An include on the top to the effect of:

require_once( ABSPATH . WPINC . '/pluggable.php' );

will sort it out (please be sure to either change the bottom require to require_once, or remove it altogether).

Blocker, because it breaks functionality.

Tested on stock 3.2.1 with no plugin active.

Change History (1)

#1 @duck_
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Cannot reproduce.

spawn_cron() is called by wp_cron() which is hooked into the sanitize_comment_cookies which is fired after loading pluggable.php.

Note: See TracTickets for help on using tickets.