Make WordPress Core

Opened 4 years ago

Last modified 11 months ago

#18136 reopened defect (bug)

WordPress Adding Spurious </p>

Reported by: singpolyma Owned by:
Milestone: Future Release Priority: normal
Severity: normal Version:
Component: Formatting Keywords: wpautop has-patch
Focuses: Cc:


If you look at this page: https://singpolyma.net/2011/06/dystoparx-part-12/ WordPress seems to be adding extra </p> tags before the </div>s This causes major well-formedness problems on the page.

Attachments (2)

Autop-18136.diff (604 bytes) - added by jond 14 months ago.
Autop.php unit test coverage for #18136
Autop-18136-fixed.diff (605 bytes) - added by jond 14 months ago.
Fixed expected results

Download all attachments as: .zip

Change History (21)

comment:1 @nacin4 years ago

Please post the HTML you have in your post content. We need before and after.

comment:2 @nacin4 years ago

  • Keywords reporter-feedback added

comment:3 @ipublicis3 years ago

I checked the code on some of the other more recent posts and it doesn't show anymore. This has more than one year. Shouldn't it be closed?

comment:4 @SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed

There are still excess </p> tags in the linked post, but I couldn't reproduce the issue by copying the content from the HTML source (also tried switching to visual editor and back to HTML) neither in 3.4 nor in current trunk.

Free free to reopen with steps to reproduce if there's still a problem.

comment:5 @singpolyma3 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened


That's the input as showing on my WP dashboard. I tried saving again and with X-Valid turned off as well, just in case that was transforming it (but it's not, still shows as fine in the dashboard), but it's still got the extra </p> in the page.

comment:6 @singpolyma3 years ago

  • Keywords reporter-feedback removed

comment:7 @SergeyBiryukov3 years ago

  • Milestone set to Awaiting Review

Confirmed when pasting the linked input into HTML (Text in 3.5) editor, saving and viewing the post.

After switching to visual editor and back, the extra </p> is gone.

comment:8 @singpolyma3 years ago

I enabled the visual editor, switched to it and then switched back, and it broke some of my other markup, but after fixing that it does seem to be a workaround for the issue.

Still seems like a bug, though.

comment:9 @azaozz3 years ago

Got it down to this:

  • Extra closing P
    <div><p>123</p> </div> 
  • Works as expected

Generally autop should ignore the whole content as there are no line breaks in there. What happens in this case: autop inserts a line break after the </p> and then threats the white space as another row.

A temporary workaround would be to remove all spaces between block tags.

comment:11 @Japh3 years ago

  • Cc japh@… added

comment:12 @mbijon3 years ago

  • Cc mike@… added

Related: #21689
(via @Japh)

comment:13 @nacin21 months ago

  • Keywords wpautop added

comment:14 @nacin21 months ago

  • Keywords needs-unit-tests added
  • Milestone changed from Awaiting Review to Future Release

comment:15 @ircbot19 months ago

This ticket was mentioned in IRC in #wordpress-dev by SergeyBiryukov. View the logs.

@jond14 months ago

Autop.php unit test coverage for #18136

comment:16 @jond14 months ago

Added test coverage based on @azaozz findings.

@jond14 months ago

Fixed expected results

comment:17 @MikeHansenMe11 months ago

  • Keywords needs-patch added; needs-unit-tests removed

Looks like this still needs a patch but already has unit tests.

comment:18 @jond11 months ago

@MikeHansenMe See the patch applied to #27350. The fix for #27350 also fixes #18136 and passes unit tests.

comment:19 @jond11 months ago

  • Keywords has-patch added; needs-patch removed
Note: See TracTickets for help on using tickets.