WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18159 closed defect (bug) (worksforme)

Automatic Plugin and Theme Upgrade Fails

Reported by: Adeptris Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2
Component: General Keywords:
Focuses: Cc:

Description

I did do a search and found this, but it was from 8 months ago.
http://core.trac.wordpress.org/ticket/15575

I have had this issue as well as another forum topic authors, I was not sure at first if it was just something with Windows server or WordPress, but others are reporting the same thing.

I have had this when updating two plugins and the twenty eleven theme.

This is what happened in my case, the plugins 'include' folder and the themes 'inc' were not deleted, could this be because a script in the folder was in use on the admin page?
.
.

http://digitalraindrops.net/images/bookmarks.png

.
.
When I upgraded the twenty eleven theme from admin then I am using the files in the /inc/ folder.

When the update tries to copy the files access to the include folder is denied.

Using FileZilla the folder still exists but will not delete or rename.

The file could also be seen in the ISP control panel File Manager, and could not be accessed, renamed or deleted, although file permissions are correct.

A manual transfer of files and it looks like a file cannot be replaced and causes this problem.
.
.
http://digitalraindrops.net/images/bookmarks-2.png
.
.
I have to wait 30 minutes for error to clear and the folder to dissapear, so I am not sure if it is a WordPress or Windows server problem.

From Today:
An error occurred while updating WordPress Importer: Could not create directory. D:/digitalraindrops.net/wwwroot/wp-content/plugins/wordpress-importer/

I have been using the auto upgrade for the last two years, my ISP has said nothing has changed on the server and the upgrade should work!

Regards

David

Change History (16)

comment:1 ocean903 years ago

Which WordPress version?

comment:2 adeptris3 years ago

Since 3.2.0, before this no problem, and only plugins and themes so far, the latest 3.1.2 to 3.2.0 and then WordPress 3.2.1 upgraded no problem, so it is not likely a permissions thing as this would have failed.

First sexybookmarks failed two upgrades, so I posted in the forum thinking it was the plugin, then the twenty eleven theme 1.2 upgrade failed, and today the WordPress Importer plugin upgrade failed.

Regards

David

Last edited 3 years ago by adeptris (previous) (diff)

comment:3 ocean903 years ago

  • Version set to 3.2

comment:4 dd323 years ago

  • Keywords reporter-feedback added

This doesnt appear to be caused by WordPress, The FTP Server is running into Filesystem ACL's which prevent access to certain folders it appears to me. Given this is a Windows Environment, PHP can't actually modify these ACL's so can't have set them directly in the first place.

Does your FTP client give you the 'chmod'/file permissions fields? It could be that the server is translating a Unix chmod value into a Windows ACL incorrectly (or vice versa).

The file could also be seen in the ISP control panel File Manager, and could not be accessed, renamed or deleted, although file permissions are correct.

This also seems to indicate a server issue, The File manager should be running with higher privledges than WordPress, and as such, should be able to modify those files. If the hosts control panel can't access said files, I can't expect WordPress would be able to access them either.

comment:5 adeptris3 years ago

I will give your feedback to my ISP, it is strange that it has just started to happen since I upgraded but allowed the core upgrade to 3.2.1 but not the plugins or theme upgrades

I will also try the next update with a different browser as IE9 has also played up sometimes.

I see you mention the ftp preventing access to certain folders, but the second screenshot, the folder looked to still exist but the file could not be written, WordPress Importer is a tiny plugin just three files and a language folder.

Thanks

David

Last edited 3 years ago by adeptris (previous) (diff)

comment:6 adeptris3 years ago

Tested with FireFox:

The update process is starting. This process may take a while on some hosts, so please be patient.

Enabling Maintenance mode…
Updating Plugin Mingle Forum (1/1)

Downloading update from http://downloads.wordpress.org/plugin/mingle-forum.1.0.31.zip
Unpacking the update…
Installing the latest version…
Removing the old version of the plugin…
Plugin update failed.

An error occurred while updating Mingle Forum: Could not remove the old plugin..

Disabling Maintenance mode…

All updates have been completed.

Same Problem:
All files and folders deleted except one, it is always one folder or file that fails, I am not convinced it is a server issue as it has just started to happen.

David

Last edited 3 years ago by adeptris (previous) (diff)

comment:7 adeptris3 years ago

Small Plugin Updated today no error.

Another user opened a topic in the forum
http://wordpress.org/support/topic/how-to-fix-an-error-occurred-while-updating-could-not-create-directory?replies=4#post-2234012

I still think the problem is the WordPress plugin and theme upgrade functions, as we would have all sorts of other issues when activating and deactivating plugins and functions that write and delete folders and files to wp-content as well.

Regards

David

Last edited 3 years ago by adeptris (previous) (diff)

comment:8 dd323 years ago

I still think the problem is the WordPress plugin and theme upgrade functions

There may be a bug in it with certain server configurations, However, I cant duplicate the problem.
Your screenshots clearly show the FTP server is denying WordPress the STORE (create) and CWD (change directories) commands, those are unfortunately, out of control of WordPress - So it's a bit hard to nail it as a bug in the upgrader (thats working for many thousands of others).

I'll repeat my question from earlier:

Does your FTP client give you the 'chmod'/file permissions fields? It could be that the server is translating a Unix chmod value into a Windows ACL incorrectly (or vice versa).

I'd like to see the permission set that the files have according to the FTP Server.

Same Problem: All files and folders deleted except one, it is always one folder or file that fails, I am not convinced it is a server issue as it has just started to happen.

Just because it happened at approximately the same time, it doesnt always mean the upgrade caused it,
There were 3 changes to the upgrade code in 3.2:

  • [17525] affected the FTP class, caches known data, significantly sped up FTP operations and fixed a lot of FTP Servers becoming unresponsive. You can check to see if this caused it by reverting to the 3.1 files for wp-admin/includes/class-wp-filesystem-*.php
  • [17590] affected deleting the previous versions folders - There should be no logical changes there, You can try using the 3.1 version of wp-admin/includes/class-wp-upgrader.php to test that, note that Core Updates will fail if you do that.
  • [18225] and [18227] - Only affects Core upgrades, not plugins.

From what you've said, This sounds like it's a Shared hosting environment (ie. Not a dedicated windows VM?), Is there any chance of me having a first-hand look at it? (with a test install or account) for that matter, have you tried another instance of WordPress on the same server? feel free to contact me via email if you're able to provide any help there: wordpress [at] dd32.id.au

comment:9 dd323 years ago

Also, Forgot to mention, Can you provide as many details as possible about the server environment?

  • Version of Windows
  • HTTP server and version (if known)
  • FTP Server and version (can find it in the initial headers when you connect via FTP)
  • version of PHP as well
  • If the PHP FTP Extension is loaded (check phpinfo(), if you could post a link to that as well it'd be appreciated, email would be fine too)

comment:10 dd323 years ago

This sounds more and more like a FTP Server / Filesystem cache issue based on the reporters support forum thread:

I have to wait 30 minutes for error to clear and the folder to dissapear, so I am not sure if it is a WordPress or Windows server problem.

If The folders are deleted after 30 minutes, or installs complete when you attempt them 30minutes after a failed upgrade, this is definately a server issue.

comment:11 adeptris3 years ago

I have sent all the details, many thanks for looking at this.

There is a test database in a sub folder where the twenty eleven theme upgrade failed, maybe load version 1.1 and then upgrade from the WordPress upgrade screen to 1.2 is one scenario that would be easy to replicate.

The Google Sitemap plugin on the main site updated just fine this morning.

Once again thanks you for your understanding and input.

David

comment:12 adeptris3 years ago

I think I may have found the problem, as I am on a windows server that offers WinCache.

Have a read here: http://blogs.iis.net/ruslany/archive/2011/04/14/wincache-and-wordpress-plugin-upgrade-problem.aspx.

Please Advise:
I am using Faster PHP Version 5.3 IonCube with Microsoft WinCache
I can downgrade to a Slower PHP Version 5.2 with IonCube and Zendloader, until a fix is found?

Are the devs aware of the WinCache issue?

So it does look like a server issue after all! :(

David!

Last edited 3 years ago by adeptris (previous) (diff)

comment:13 Adeptris3 years ago

Hi d32,
My ISP is going to upgrade the Microsoft WinCache on their servers over the next few days.

Here are links to some articles for anyone searching trac, I did search here and in the forum but WinCache was never returned in the search.

http://forums.iis.net/t/1169832.aspx

http://wordpress.org/support/topic/wordpress-on-iis-7-plugin-update-problem?replies=33

http://ruslany.net/2011/04/wincache-and-wordpress-plugin-upgrade-problem/

Thanks for the input.

Regards

David

Last edited 3 years ago by Adeptris (previous) (diff)

comment:14 Adeptris3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Just to confirm, my hosting company upgraded wincache to the latest release and the plugins will now upgrade with no problem.

David

comment:15 ocean903 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution fixed deleted
  • Status changed from closed to reopened

It's not fixed by WordPress, so...

comment:16 ocean903 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

..just works for me.

Note: See TracTickets for help on using tickets.