Make WordPress Core

Opened 13 years ago

Closed 9 years ago

#18188 closed enhancement (fixed)

Make it easier to go between Dashboard and site edit pages

Reported by: novasource's profile novasource Owned by: petemall's profile PeteMall
Milestone: 4.3 Priority: normal
Severity: normal Version: 3.1
Component: Networks and Sites Keywords: ui-feedback
Focuses: multisite, administration Cc:

Description

Each site in a network install has a Dashboard and a set of "edit" pages (Info/Users/Themes/Settings).

The "edit" page URLs are /wp-admin/network/site-settingsName.php?id=id where settingsName is info, users, themes, or settings. The Dashboard URL is /siteName/wp-admin/ where siteName is, I think?, the site's Path field as shown in /wp-admin/network/site-info.php?id=id but without the leading and trailing slashes.

The problem is if I am in the "edit" pages and want to go to the site's dashboard, I have to click on Sites, then hunt down the site in the list, then click Dashboard while hovering the mouse over the site's row. I have a similarly convoluted process to get from a Dashboard to the "edit" pages.

Does this need to be so complicated? It would be nice for network admins to see links on every Dashboard or "edit" page that allows the user to go back and forth between the two easily.

Or even better, how about making the "edit" pages just show up as additional items in the Dashboard?

Attachments (4)

18188.diff (802 bytes) - added by ryan 12 years ago.
Add "Edit Site" submenu to admin bar site menu.
Screen Shot 2012-02-07 at 12.07.35 PM.png (19.2 KB) - added by ryan 12 years ago.
18188.2.diff (820 bytes) - added by ryan 12 years ago.
18188.3.diff (4.7 KB) - added by ryan 12 years ago.
Bring site being edited up to primary

Download all attachments as: .zip

Change History (17)

#1 @nacin
13 years ago

  • Milestone changed from Awaiting Review to 3.3
  • Owner set to PeteMall
  • Status changed from new to assigned

#2 @PeteMall
13 years ago

  • Version changed from 3.2.1 to 3.1

#3 @ryan
13 years ago

  • Milestone changed from 3.3 to Future Release

Punting enhancements from 3.3.

#4 @DrewAPicture
12 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

I believe this was fixed with the new My Sites menu in the 3.3 Toolbar, well, in one direction at least.

Last edited 12 years ago by DrewAPicture (previous) (diff)

#5 @SergeyBiryukov
12 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

The only change to My Sites menu in 3.3 seems to be moving Network Admin there. Not sure if it fixes the described issue — the same steps are still required to go from a site edit page to its Dashboard.

#6 @PeteMall
12 years ago

  • Keywords ui-feedback added
  • Milestone changed from Future Release to 3.4

@ryan
12 years ago

Add "Edit Site" submenu to admin bar site menu.

#7 @ryan
12 years ago

Patch adds an "Edit Site" submenu to the admin bar site menu when a super admin visits a blog's dashboard.

@ryan
12 years ago

#8 @ryan
12 years ago

In [19855]:

Add an "Edit Site" submenu to the admin bar site menu when a super admin visits a blog dashboard. see #18188

#9 @ryan
12 years ago

On the Network Admin side, My Sites could drop the Network Admin menu and replace it with the site being edited when visiting the site-*.php pages.

@ryan
12 years ago

Bring site being edited up to primary

#10 @ryan
12 years ago

PoC, but this is a bit of an abuse of My Sites and may be too clever.

Since the Users, Themes, and Settings tabs have analogous pages in the site admin, perhaps linking to those pages directly in the tabs is best.

#11 @ryan
12 years ago

  • Milestone changed from 3.4 to Future Release

#12 @nacin
10 years ago

  • Component changed from Network Admin to Networks and Sites
  • Focuses administration added

#13 @jeremyfelt
9 years ago

  • Milestone changed from Future Release to 4.3
  • Resolution set to fixed
  • Status changed from reopened to closed

I missed this ticket when we did #32525, which completed the second half.

  • "Edit Site" in the site dashboard was added on this ticket in [19855]
  • A link back to the dashboard was added in the site edit screen in [33186]

I think this solves the overall problem of going cleanly between editing a site at the network level and managing a site at the site level.

Note: See TracTickets for help on using tickets.