WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#1819 closed defect (bug) (worksforme)

extra <a href="http://www.LINK.org" /> links "Posted in"

Reported by: carnaticwm Owned by:
Milestone: Priority: normal
Severity: minor Version: 1.6
Component: Administration Keywords: tinymce
Focuses: Cc:

Description

please do the following - i could reproduce the issue at kishore.wordpress.com as well as a local install

1) write post

2) title: testing

3) body:

3-a) type: kishore

3-b) mark: kishore

3-c) click on "insert/edit link"

3-d) for the url, enter: http://www.kishore.org

3-d) press END ( to reach end of word )

-> you are now at next line

3-e) type: kishore1

3-f) publish

EDIT the entry and see the html -> it contains

<p><a href="http://www.kishore.org">kishore.org</a></p>
<p>kishore </p>
<a href="http://www.kishore.org" />

the third line is unexpected and seems to be a bug !

Change History (7)

comment:1 @markjaquith10 years ago

  • Keywords tinymce added
  • Version changed from 1.2 to 1.6

comment:2 @westi10 years ago

Ok I had a play at this...

Between 3)d and 3)e you need to press enter..

Looking at the html after that point the code is already incorrect no need to save and re edit.. so def a tinymce issue

comment:3 @thorie10 years ago

i was able to reproduce the bug
be sure to hit END, then hit ENTER to go to the next line, then type something
when you post, you'll get that extraneous tag

comment:4 @thorie10 years ago

i downloaded the new tinyMCE (version 2, RC 4) into the scripts directory
and that seems to fix this bug.

comment:5 @davidhouse10 years ago

  • Severity changed from normal to minor

Not a major bug (the extra links are invisible), nor is it a problem with WP (it's TinyMCE), so I'm setting severity to minor.

comment:6 @Nazgul9 years ago

  • Milestone set to 2.1
  • Resolution set to worksforme
  • Status changed from new to closed

Seems to have been fixed in the meantime.

comment:7 @Nazgul8 years ago

  • Milestone 2.1 deleted
Note: See TracTickets for help on using tickets.