WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18205 closed feature request (invalid)

Comments Reply Link Appears When Comments Closed

Reported by: mithrill Owned by:
Milestone: Priority: normal
Severity: trivial Version: 3.2.1
Component: Comments Keywords: ux-feedback
Focuses: Cc:

Description

The comment_reply_link() appears even when comments are closed. Although the reply link does not allow comments to be posted when comments are closed on a post, it would be good from a user experience perspective to not even display the comments reply link when comments are closed.

Change History (3)

comment:1 follow-up: @SergeyBiryukov4 years ago

Can't reproduce in 3.2.1 with Twenty Ten or Twenty Eleven. The Reply link disappears after closing comments. There's a check in get_comment_reply_link():

if ( !comments_open($post->ID) )
	return false;

comment:2 in reply to: ↑ 1 @mithrill4 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Thanks for the quick reply. I'm not using a default theme, but the issue didn't appear to be with my theme since it relies on the code comment-template.php. I'll keep digging around to see if I can resolve this.

Replying to SergeyBiryukov:

Can't reproduce in 3.2.1 with Twenty Ten or Twenty Eleven. The Reply link disappears after closing comments. There's a check in get_comment_reply_link():

if ( !comments_open($post->ID) )
	return false;

comment:3 @SergeyBiryukov4 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.