WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 9 months ago

Last modified 9 months ago

#18225 closed enhancement (wontfix)

Sub-blog on Network site redirects to wrong URL for user registration

Reported by: amereservant Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.2.1
Component: Multisite Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

When a user clicks on the register button of a sub-blog, it redirects the user to the signup form on the primary blog, which means they end up creating an account with it instead of the sub-blog.

When the user tries accessing the sub-blog login after activation, they are denied access because the registration took place with the parent blog instead. There's also no way to transfer users to another blog.

This issue sounds similar to the one in #16866 , but it's not a feature request, instead it's a bug.

My test case is:
network blog is installed in sub-directory, such as http://mydomain.com/blogs/.
A sub-blog is created at say http://mydomain.com/blogs/my-sample-blog/.
I register a new user account with the sub-blog, which takes me to http://mydomain.com/blogs/wp-signup.php instead of http://mydomain.com/blogs/my-sample-blog/wp-signup.php.

Running on Ubuntu 10.04, Apache 2, PHP 5.3, WordPress 3.2.1.

Change History (8)

comment:1 amereservant3 years ago

I've found the problem ... in wp-signup.php, line 30 redirects the user if !is_main_site(), so it takes them to the signup form on the main site instead, thus causing the user to register with the wrong site.

comment:2 sillybean3 years ago

  • Cc steph@… added

comment:4 wpmuguru18 months ago

  • Type changed from defect (bug) to enhancement

This is not a bug. WordPress MU worked exactly the same way.

comment:5 SergeyBiryukov18 months ago

  • Description modified (diff)

comment:6 Ipstenu18 months ago

To clarify on what wpmuguru said, this isn't a bug because you're not being added to the blog at all, you're being added to the network, which is run from the main site. You can write a per-site registration page for your sites if you wanted to (I wrote a plugin that helps do this). At any rate, you don't 'transfer' users between blogs, they don't get added to any blogs on registration last I checked, but to the network. They become psudeo subscribers to all sites on the network, and each site can add users to their individual sites.

comment:7 amereservant9 months ago

  • Resolution set to wontfix
  • Status changed from new to closed

comment:8 helen9 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.