WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18247 closed defect (bug) (fixed)

Alignment buttons doesn't work if there is no content in editor under RTL

Reported by: Tomer Owned by:
Milestone: 3.3 Priority: normal
Severity: normal Version:
Component: RTL Keywords: has-patch
Focuses: Cc:

Description

When starting to compose a new post, and clicking on the alignment buttons right away, the user may not see the alignment change.

Steps to reproduce:
Using RTL WordPress, compose new post/page, and click on the left align button.

Current result:
Text is still starting on the right edge of the editor.

After adding non-aligned content, the text goes to the right position. This is caused because the box element has no specified size, and can be fixed by either setting size on html .mceContentBody or removing the float:right from the element.

Attachments (2)

Screenshot-2.png (24.5 KB) - added by Tomer 3 years ago.
screenshot
18247.patch (1.5 KB) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (4)

Tomer3 years ago

screenshot

SergeyBiryukov3 years ago

comment:1 SergeyBiryukov3 years ago

  • Keywords has-patch added
  • Milestone changed from Awaiting Review to 3.3

18247.patch should fix that for Twenty Eleven and Twenty Ten. Also, the content of Twenty Ten's editor-style-rtl.css introduced in [14466] was duplicated for some reason.

comment:2 azaozz2 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In [19085].

Note: See TracTickets for help on using tickets.