WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#18278 closed defect (bug) (duplicate)

Plugins aren't loaded on wp-activate.php

Reported by: johnbillion Owned by:
Milestone: Priority: normal
Severity: major Version: 3.2.1
Component: Multisite Keywords:
Focuses: Cc:

Description

example.com/wp-activate.php loads the theme's functions.php file and calls get_header() and get_footer(), but plugins aren't loaded. This causes inconsistency with every other page on a site.

So wp-activate.php has an identity problem. Is it part of the theme? Or is it part of administration like wp-login.php? If it is part of the theme, it needs to work much better than it does (ie. there's no way to override the markup on the page without the theme hooking into activate_header and overriding the entire page).

3.2.1 Multisite

Related: #17761

Change History (5)

comment:1 @johnbillion4 years ago

My personal opinion is that this page should behave more like wp-login.php. We could even deprecate wp-activate.php and use wp-login.php?action=activate&key=foo in the same way wp-register.php was deprecated.

comment:3 follow-up: @nacin4 years ago

At the very least, network-wide plugins are activated.

Think this is safely a duplicate of #17948.

comment:4 in reply to: ↑ 3 @johnbillion4 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to nacin:

Think this is safely a duplicate of #17948.

comment:5 @ocean904 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.