Make WordPress Core

Opened 4 years ago

Closed 2 days ago

#18292 closed enhancement (wontfix)

Not interrupting the network update, even if errors are detected

Reported by: luuzan@… Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Upgrade/Install Keywords: has-patch needs-testing
Focuses: multisite Cc:


My installation
3.2.1 multi-site installation with almost 8000 sites.

The issue
During the network update, I kept getting this error message :
Warning! Problem updating http://username.example.com. Your server may not be able to connect to sites running on it. Error message: 0: Empty reply from server.
The problem is that the network update script (/wp-admin/network/upgrade.php) dies every time an error is detected, so I had to reload the page every time. With nearly 8000 sites to update, it was impossible, so I modified that script.

Suggested enhancement
Enhance the network update script so that it doesn't die at each error, logs the error and continues. A second run on the unsuccessful upgrades would also be nice.

Attachments (2)

18292.patch (1.6 KB) - added by SergeyBiryukov 4 years ago.
18292.diff (1.4 KB) - added by jeremyfelt 4 days ago.

Download all attachments as: .zip

Change History (16)

comment:1 @ocean904 years ago

Related: #11869

comment:2 @luuzan@…4 years ago

And what would be even sweater is the possibility to choose

  • the batch size : upgrade 5 blogs at once or 10, 20, etc
  • the timeout of the requests : 120 seconds or 300 seconds, etc

In my case, what seemed to have solved to problem is increasing the timeout to 300 seconds.

comment:3 @SergeyBiryukov4 years ago

  • Keywords needs-patch added

@SergeyBiryukov4 years ago

comment:4 @SergeyBiryukov4 years ago

  • Keywords has-patch added; needs-patch removed

18292.patch would allow to continue updating the remaining sites.

Doesn't touch UI, leaving that for #11869.

comment:5 @SergeyBiryukov4 years ago

  • Component changed from Upgrade/Install to Multisite

comment:6 @nacin4 years ago

  • Milestone changed from Awaiting Review to 3.4

comment:7 @bigdawggi4 years ago

  • Cc matt@… added

comment:8 @nacin4 years ago

The problem is that doing this will still cause the JS to fire, which means you'll only see the error message if you're paying attention. We really should just implement #11869.

comment:9 @ryan3 years ago

  • Milestone changed from 3.4 to Future Release

comment:10 @jeremyfelt21 months ago

  • Component changed from Multisite to Upgrade/Install
  • Focuses multisite added

@jeremyfelt4 days ago

comment:11 @jeremyfelt4 days ago

  • Keywords needs-testing added
  • Milestone changed from Future Release to 4.4

I was about to close this and defer to #11869 for our long term goals, but then realized I've been using a modified version in production for a bit. :)

18292.diff outputs the warning and stops the auto-next behavior if a warning is output.

This will result in an output of 5 sites each time, with those that have errors listed among those that were successful.

It may be worth it to put this in now while the right time for #11869 awaits.

Feedback and testing, please!

comment:12 @slackbot3 days ago

This ticket was mentioned in Slack in #core-multisite by jeremyfelt. View the logs.

comment:13 @slackbot2 days ago

This ticket was mentioned in Slack in #core-multisite by jeremyfelt. View the logs.

comment:14 @jeremyfelt2 days ago

  • Milestone 4.4 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This is a case where we can do a lot better by re-evaluation the process used during a network upgrade. Closing this in favor of #11869, which should also take this scenario into account.

Note: See TracTickets for help on using tickets.