WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#18309 closed defect (bug) (fixed)

Update to SimplePie 1.2.1

Reported by: pagesimplify Owned by: ryan
Milestone: 3.4 Priority: normal
Severity: normal Version: 3.2.1
Component: External Libraries Keywords: dev-feedback needs-testing
Focuses: Cc:

Description

File:

http://core.svn.wordpress.org/tags/3.2.1/wp-includes/class-simplepie.php :: Line 8485

Class Name:

class SimplePie_gzdecode

Class Method:

function parse()

Reference:

NOTE: I reported this issue on simplepie.org as seen below.

The same issue exists in WordPress file:

  • /wp-includes/class-simplepie.php on Line 8485

Description:

SimplePie_gzdecode class method parse() attempts to reference a class property with the following line:

$position += 2;

The line should be modified as:

$this->position += 2;

Attachments (2)

simplepie-1-2.diff (1.3 KB) - added by nacin 2 years ago.
simplepie-1-2-1.diff (72.6 KB) - added by nacin 2 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 kawauso3 years ago

  • Component changed from Feeds to External Libraries

comment:2 follow-up: Otto423 years ago

Suggest tabling this until the upstream fixes it, then catching it in a sync.

comment:3 in reply to: ↑ 2 pagesimplify2 years ago

  • Cc pagesimplify added

Replying to Otto42:

Suggest tabling this until the upstream fixes it, then catching it in a sync.

The SimplePie_gzdecode Patch I submitted to SimplePie was accepted and committed.

I originally reported this issue for class-simplepie.php - WordPress 3.2.1 which was using SimplePie version 1.2 (released June 27, 2009).

SimplePie has been updated to SimplePie version 1.2.1 (released October 15, 2011)

class-simplepie.php - WordPress 3.3.1 is still using SimplePie version 1.2.

BTW Otto, this is David Carroll, we met at WordCamp Atlanta this past weekend.

comment:4 pagesimplify2 years ago

  • Keywords needs-testing added

comment:5 nacin2 years ago

  • Milestone changed from Awaiting Review to 3.4
  • Summary changed from Fix SimplePie_gzdecode Code Typo to Update to SimplePie 1.2.1

The diff for 1.2.1 is quite large, but a lot of it appears to be whitespace. I've pinged the SimplePie maintainer (rmccue) to take a look here. Let's update it.

nacin2 years ago

nacin2 years ago

comment:6 nacin2 years ago

simplepie-1-2.diff is a diff of a clean SimplePie 1.2, based on commit 3403fd07b7. (The 1.2 tag on Github is not pristine and has some 1.2.1-dev stuff in it.)

For reference, the class_exists() is required to avoid conflicts with plugins including SimplePie separately. Additionally, there is [12528] and [13935], both deliberately done out-of-stream, and [16699], which I mistakenly applied to the library.

simplepie-1-2-1.diff is a diff for SimplePie 1.2.1. It's about 2,000 lines long, and reverts to the misspelling of occurred. :-)

comment:7 pagesimplify2 years ago

Thanks for taking the time to review the diffs. I never realized there were so many spelling variations of "ocurred" or rather "occured" or um, maybe, "occurred" :)

comment:8 pagesimplify2 years ago

  • Cc pagesimplify removed

comment:9 pagesimplify2 years ago

  • Cc pagesimplify added

comment:10 rmccue2 years ago

Wow, totally missed that I left a -dev in the version string there.

In terms of API compatibility, 1.2.1 shouldn't break anything, so it should be fine to merge in.

You can also take a look at the commit log and the issue tracker for what was fixed (might be worth mentioning in the commit message).

Any questions about the update?

comment:12 ryan2 years ago

  • Owner set to ryan
  • Resolution set to fixed
  • Status changed from new to closed

In [19890]:

Upgrade SimplePie to 1.2.1. Props nacin. fixes #18309

comment:13 rhertzog2 years ago

  • Cc hertzog@… added

I had SimplePie 1.2.1 on WordPress 3.3.1 by mistake and it broke WP with this errror:

PHP Fatal error: Cannot make static method SimplePie_Cache::create() non static in class WP_Feed_Cache in /usr/share/wordpress/wp-includes/class-feed.php on line 6

I don't see any change to that file in trunk to avoid this problem so I wonder what this means...

comment:14 rhertzog2 years ago

Forget about my question, the problem is Debian specific with changes introduced in the SimplePie class (see http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=651515 for details of the patch which marked the create method as static).

Note: See TracTickets for help on using tickets.