WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

Last modified 2 years ago

#18312 closed defect (bug) (duplicate)

Bug when using WordPress should correct invalidly nested XHTML automatically with lists

Reported by: racqnhack Owned by: racqnhack
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Formatting Keywords:
Focuses: Cc:

Description

To duplicate:

Enable "WordPress should correct invalidly nested XHTML automatically" in Settings -> Writing

Create new page.

Create new bullet list with nested list

Hit Preview and see that lists (html) are coming out different.

Then, disable and try again and see that lists work now.

I can duplicate this on all my wp sites.

Attachments (1)

18312.diff (8.1 KB) - added by kurtpayne 3 years ago.
New version of force_balance_tags function

Download all attachments as: .zip

Change History (11)

comment:1 racqnhack3 years ago

  • Keywords needs-patch added; reporter-feedback removed

comment:2 kawauso3 years ago

  • Keywords needs-testing removed

kurtpayne3 years ago

New version of force_balance_tags function

comment:3 kurtpayne3 years ago

  • Cc kurtpayne added
  • Keywords has-patch added; needs-patch removed

I can confirm the problem as well. I did some extra testing on this and found the problem with other nested types like dictionary lists, too. I have rewritten the force_balance_tags function to loop through nested tags differently to avoid this problem. I also added the ability to skip balancing tags inside certain tags (like script and style) where it may be problematic.

Thoughts?

comment:4 nacin3 years ago

  • Severity changed from critical to normal

comment:5 racqnhack3 years ago

Looks like this may be due to a TinyMCE upgrade to 3.2.1 not working with _balance_tags properly.

comment:6 racqnhack3 years ago

  • Keywords has-patch removed

Tested patch and it did not change the results, as mentioned before this is not just a problem with the function.

This appears to be something to be fixed in 3.3 with TinyMCE upgrade (in which this has been fixed).

comment:7 racqnhack2 years ago

  • Resolution set to duplicate
  • Status changed from new to closed
Version 0, edited 2 years ago by racqnhack (next)

comment:8 racqnhack2 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:9 racqnhack2 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate (same issue with TinyMCE) of: http://core.trac.wordpress.org/ticket/18261

comment:10 SergeyBiryukov2 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.