WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18317 closed defect (bug) (duplicate)

Navigation menus from pages duplicates post content in database

Reported by: Nazgulled Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Database Keywords: redundancy dev-feedback
Focuses: Cc:

Description

I've decided to post this here (instead of the support forums) because I think this is a bug and not by design. I tried to search for this but didn't find much, so I have no idea if this is really a bug or not.

I only found this:
http://core.trac.wordpress.org/ticket/14576

But the OP was having a different problem and I just want to report the database problem. Or understand if it's by design and why.

Basically, creating navigation menus using previously created pages, will duplicate that specific page content into the menu entry in the database. If the page is updated, the post_content of the corresponding menu record will not be updated.

I normally clear the post_content for any menu record in the wp_posts table cause the way I see it, this content is redundant.

Am I missing something and this is by design?

Change History (2)

comment:1 Nazgulled3 years ago

  • Keywords redundancy added

comment:2 SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.