WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 11 months ago

Last modified 11 months ago

#18324 closed defect (bug) (worksforme)

after adding new template file, "Template" drop-down disappears

Reported by: sjscitp Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Themes Keywords: reporter-feedback
Focuses: template Cc:

Description

After adding a new page template to my theme, the "Template" drop-down on the add/edit page screen disappeared. The "Parent" and "Order" form inputs still appeared, but there was no reference to the "Template" drop-down form element in the "view source" HTML of the page.

The new template file had been added to my theme directory via pull from a git repo that my collaborator had pushed the file to. The "Template" drop-down worked fine on his exact copy of the theme.

I changed the theme for my site to twentyeleven and then immediately back to my custom theme, and the "Template" drop-down began appearing again. I did this at the suggestion of these pages:

http://stackoverflow.com/questions/3987773/

http://wordpress.org/support/topic/template-file-drop-down-not-appearing

Evidently this intermittent bug has appeared since before Wordpress 3.

Change History (4)

comment:1 @nacin19 months ago

  • Component changed from Template to Themes
  • Focuses template added

comment:2 @obenland19 months ago

  • Keywords reporter-feedback added

I could not reproduce the bug in my test install. Does it still occur for you in the latest version of WordPress?

comment:3 @obenland11 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
  • Version 3.2.1 deleted

Still can't reproduce it.

sjscitp, please feel free to reopen the ticket with steps to reproduce the issue.

comment:4 @SergeyBiryukov11 months ago

  • Version set to 3.2.1
Note: See TracTickets for help on using tickets.