WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 11 months ago

Last modified 11 months ago

#18325 closed defect (bug) (worksforme)

TinyMce, noscript, and the gallery icon.

Reported by: cmdrmatt Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

If you include the shortcode for a gallery in an html noscript tag, and switch between visual and html mode, the gallery "icon" is replaced by html addressing the icon... which shouldn't be visible in visual edit mode. If you publish the page with the html showing, it will then save the gallery shortcode and discard the noscript tags. I haven't been able to understand this behavior.

I'm trying to use a slideshow shortcode followed by a gallery shortcode in a noscript tag as a backup for those without JS. This works so long as I don't republish the page from the visual mode. Then I get a slideshow and a gallery.

I've tested it on a different site of my multisite install with no plugins on and it still occurs, so I'm relatively confident the problem is in the way tinymce handles the noscript tag.

Change History (3)

comment:1 WraithKenny3 years ago

  • Cc Ken@… added

comment:2 c3mdigital11 months ago

  • Resolution set to invalid
  • Status changed from new to closed

Testing in trunk I could not reproduce this.

I created a gallery and wrapped in noscript tags in text editor. Switched to visual and back to text multiple times. The noscript tags stayed in place and as expected in visual the gallery was not shown because the noscript was honered.

comment:3 SergeyBiryukov11 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to worksforme

Could not reproduce either.

Note: See TracTickets for help on using tickets.