WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#18337 closed enhancement (duplicate)

Help make switching between Number of Columns dragging apparent/add Ctrl-Z (or, Undo) and Ctrl-Y to admin actions

Reported by: racqnhack Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.2.1
Component: UI Keywords:
Focuses: Cc:

Description

I have got emails from people who were using WordPress that end up confused because they used switched 'Number of Columns' to 1 and back to 2. In response I would just tell them to drag them back, in fact the first time I got this, I was confused and thought it may be a bug because I expected the right to be re-populated with my items.

But, after discussing it with a few people on #wordpress we noticed why doing that could be complicated.

So, what I am suggesting is:

1) Remember the widgets that were on the right when Number of Columns to 1 was clicked. And, when Number of Columns to 2 is clicked, they are re-populated. Of course, re-dragging them will forget about the previous setup and let the user do as they wish.

2) Add an "Drag items here" to the right when Number of Columns to 1 is clicked. Then the user would know what happened. (see attached)

3) A combination of 1 and 2?

Another feature that was brought up was the ability to use CTRL-Z to undo an action like this, and CTRL-Y, of course, to re-do it. Just in case we don't have the right UI in place, such as in this case, they can just CTRL-Z (or, hit an undo from the message area) to undo it.

Attachments (1)

Add New Post ‹ Institute for Energy & the Environment — WordPress.png (189.0 KB) - added by racqnhack 4 years ago.
Screenshot of what #2 might look like

Download all attachments as: .zip

Change History (3)

@racqnhack4 years ago

Screenshot of what #2 might look like

comment:1 @SergeyBiryukov4 years ago

Related/duplicate: #14423

comment:2 @ocean904 years ago

  • Keywords dev-feedback 2nd-opinion ui-feedback needs-ui removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Other aspects to solve the issue but a duplicate of #14423.

Note: See TracTickets for help on using tickets.