WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18341 closed defect (bug) (fixed)

Previewing posts causes saves and updates to freeze in Safari 5.1

Reported by: chrisrudzki Owned by: azaozz
Milestone: 3.3 Priority: high
Severity: critical Version:
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

Previewing posts causes subsequent saves and updates to freeze, resulting in an endless spinning wheel, in Safari 5.1. The issue arises under different conditions, depending on the version of Mac OS X that Safari 5.1 is running on.

Steps to Reproduce:

Safari 5.1 on Mac OS X 10.6.8

  1. Edit or create a draft/post, and then click Save Draft or Update
  2. Preview draft/post
  3. Close preview window or don’t close preview window. Doesn’t matter.
  4. Clicking on Save Draft or Update results in endless spinning wheel

Safari 5.1 on Mac OS X 10.7

  1. Edit or create a draft, and then click Save Draft
  2. Preview draft
  3. Don’t close preview window
  4. Clicking on Save Draft or Publish results in endless spinning wheel

Issue reports:
http://en.forums.wordpress.com/topic/freezing-when-i-try-to-save-a-draft
http://en.forums.wordpress.com/topic/freezing-when-i-try-to-save-a-draft-1
http://en.forums.wordpress.com/topic/how-do-i-fix-repeated-freezing-and-other-new-problems

There are also reports of the same issue occurring with other browsers, such as Chrome: http://wordpress.org/support/topic/freezing-when-saving-a-draft
http://en.forums.wordpress.com/topic/freezes-when-saving-draft

However, I'm not able to reproduce this in Firefox 5.0.1 or Chrome 13.0.782.107 under OS X 10.6.8 or 10.7

Attachments (1)

18341.patch (725 bytes) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 duck_3 years ago

Possibly a Webkit bug and duplicate of #12778

SergeyBiryukov3 years ago

comment:2 SergeyBiryukov3 years ago

  • Keywords has-patch added

Reproduced on Safari 5.0.5 and 5.1 for Windows as well.

Attached a workaround based on the one from https://bugs.webkit.org/show_bug.cgi?id=28633#c13.

comment:3 nacin2 years ago

  • Milestone changed from Awaiting Review to 3.3
  • Priority changed from normal to high
  • Severity changed from normal to critical

This is pretty bad.

comment:4 azaozz2 years ago

The WebKit bug was fixed on 2011-09-15, not sure how long until it gets in Chrome (Mac) and Safari. Current Mac Safari (5.1.1) still fails, so we'd need to patch it.

comment:5 azaozz2 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [19299]:

Workaround for WebKit bug when previewing posts, props SergeyBiryukov, fixes #18341

Note: See TracTickets for help on using tickets.