WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#18355 closed enhancement (duplicate)

Request to include 'object' in $default_no_texturize_tags of formatting.php - or more sophisticated formatting

Reported by: creacog Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1.2
Component: Formatting Keywords:
Focuses: Cc:

Description

In this post : http://blog.creacog.co.uk/2010/04/28/flex-4-spark-videodisplay-measure-overlay-skin/

I had used the HTML view of the editor to enter SWFObject (2.2) code. I found that, although not mangled in the editor, it is mangled on delivery to the user's browser such that :

<!--[if !IE]>-->

becomes...

<!--[if !IE]>&#8211;><br />

The only solution I've found so far is to edit formatting.php line 44 to ensure 'object' is added to the list of tags not to texturize...

$default_no_texturize_tags = array('pre', 'code', 'kbd', 'style', 'script', 'tt', 'object' );

Since these IE conditions for the SWFObject code are all within an enclosing object tag, this seems to ensure the code is reproduced as intended.

Would it be sensible for object to be added in this way? or can the formatting code be further enhanced to ensure IE conditionals don't get mangled.

Link to the sample SWFobject code I am following : http://code.google.com/p/swfobject/wiki/documentation#STEP_3:_Register_your_Flash_content_with_the_SWFObject_library_a

Thanks

Change History (3)

comment:1 @scribu4 years ago

I think it makes sense anyway. No point in wasting time texturizing text that the user won't see.

But, there's also a filter for adding whatever tag you want, without modifying core:

no_texturize_objects( $tags ) {
  $tags[] = 'object';
  return $tags;
}
add_filter( 'no_texturize_tags', 'no_texturize_objects' );

comment:2 @scribu4 years ago

  • Type changed from feature request to enhancement

comment:3 @SergeyBiryukov4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.