WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#18409 closed defect (bug) (fixed)

Improve compatibility with phpxref

Reported by: trepmal Owned by: nacin
Milestone: 3.3 Priority: normal
Severity: minor Version:
Component: General Keywords: has-patch
Focuses: Cc:

Description

Because of the number sign inside the html comment tag, and on the same line as the closing tag, about 56 functions in wp-includes/functions.php are not parsed by the phpxref software.

By simply moving the closing tag to the next line, the problem is fixed.

Attachments (1)

functions.diff (1.8 KB) - added by trepmal 6 years ago.
split comment into 2 lines

Download all attachments as: .zip

Change History (6)

@trepmal
6 years ago

split comment into 2 lines

#1 @nacin
6 years ago

  • Milestone changed from Awaiting Review to 3.3

This has bothered me for literally two years, but I've never noticed why it happened. Thanks!

#2 @nacin
6 years ago

Oddly, it looks fine here: xref.yoast.com/trunk/wp-includes/functions.php.source.html

#3 @nacin
6 years ago

Nevermind.

#4 @nacin
6 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In [18548]:

Break HTML comment up into two lines to prevent phpxref from choking on the rest of functions.php. props trepmal, fixes #18409.

#5 @trepmal
6 years ago

I was gonna say... :)

Also, this might be a new submit-to-commit record for me!

Note: See TracTickets for help on using tickets.