WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18416 closed defect (bug) (invalid)

Version.php - Error 500

Reported by: plugpress Owned by:
Milestone: Priority: normal
Severity: major Version: 3.2.1
Component: General Keywords:
Focuses: Cc:

Description

I installed a fresh copy of WordPress 3.2.1

When in the Admin section > Settings > General Settings and I save, I get an Error 500.

This server configuration is ok : it has PHP 5.2.10 and MySQL 5.0.

I debugged the code to see where the error was coming from. As weird as it sounds, the error comes from:

File: wp-includes/update.php

Function : _maybe_update_core

Error line: include (ABSPATH . WPINC . '/version.php'); // include an unmodified $wp_version

As a developer, I know what you're thinking: WTF ?! If I print something and exit before this line : no problem. If I try to print something after this line, I get the error 500. I checked the version.php error and it only contains variable.

I did a file_get_contents on the file and I could get the content.

Seriously, I really don't have any clue about what the problem is.

If needed, I can provide private credentials to this account so that tests can be run.

This error makes WordPress unusable. The server has all requirements asked to run WordPress.

I also have other instances (3-4) of WordPress (before 3.2) that runs without any problems on the same server.

Change History (3)

comment:1 plugpress3 years ago

Note: When I say "...and I save", I did not chagne anything. Just went to the page and saved.

And the error in the log is :

[Mon Aug 15 10:12:18 2011] [error] File does not exist: /home/mydomain/public_html/500.shtml, referer: http://mydomain.com/wp-admin/options-general.php

Last edited 3 years ago by plugpress (previous) (diff)

comment:2 azaozz3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I would suggest going through the normal install debug process, i.e. download fresh copy, extract it to your PC, upload with FTP and replace all files, etc. In any case this belongs on the support forums.

comment:3 plugpress3 years ago

Upgrading PHP to 5.3.6 solved the problem.

Is it a PHP problem ? I don't know.

Note: See TracTickets for help on using tickets.