Make WordPress Core

Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#18419 closed defect (bug) (fixed)

TinyMCE Anchor doesn't render in Visual Editor

Reported by: madtownlems's profile MadtownLems Owned by: jakemgold's profile jakemgold
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.2.1
Component: TinyMCE Keywords:
Focuses: Cc:

Description

I'm adding the Anchor button to TinyMCE via plugin with the normal method.

Excerpt:
array_push($buttons, "anchor");
return $buttons;

The Anchor button displays fine. Clicking it presents a dialog box fine. Completing the dialog box inserts the necessary HTML. However, the problem is that a little picture of an anchor is no longer visible in the Visual Editor

Attachments (1)

mce_anchor_style.patch (1.1 KB) - added by jakemgold 11 years ago.
Fixes anchor background image

Download all attachments as: .zip

Change History (10)

#1 @azaozz
11 years ago

  • Milestone changed from Awaiting Review to 3.3
  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in [18660], feel free to reopen if that still happens.

#2 @MadtownLems
11 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

3.3-beta-1 still has this issue. Re-opening like you said I could :)

#3 @jakemgold
11 years ago

  • Owner set to jakemgold
  • Status changed from reopened to accepted

#4 follow-up: @jakemgold
11 years ago

Turns out this regressed circa 3.2 from 3.1; the CSS background image stopped pointing up a level to the default skin image folder. Attaching patch.

@jakemgold
11 years ago

Fixes anchor background image

#5 @nacin
11 years ago

The other issue is that the anchor is rendered, but the default CSS places it too low, since it expects it to sit in the autosave/word count table markup. The default CSS should place it inside the editor. The main editor should customize its position for the custom case.

#6 @nacin
11 years ago

Whoops, my comment is a completely different bug.

#7 @nacin
11 years ago

Confirmed that the background image is missing when you add in an anchor button.

#8 @nacin
11 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In [19190]:

Correct TinyMCE anchor (as in <a name>) image. props jakemgold, fixes #18419.

#9 in reply to: ↑ 4 @SergeyBiryukov
11 years ago

Replying to jakemgold:

Turns out this regressed circa 3.2 from 3.1; the CSS background image stopped pointing up a level to the default skin image folder.

http://core.trac.wordpress.org/changeset/17625#file64

Note: See TracTickets for help on using tickets.