WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 5 years ago

#18527 closed enhancement (duplicate)

Duplicate Menu Option or Add a Hook for Plugins

Reported by: wpsmith Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3
Component: Menus Keywords: has-patch
Focuses: administration Cc:
PR Number:

Description

It would be great to add a hook for plugins to be able to add options, etc, to Appearance > Menus. One thing would be to have the option to duplicate a menu.

I have worked up a patch that accomplishes this, which would serve as a good starting point for adding duplication functionality.

Attachments (1)

duplicate-nav-menu.patch (4.7 KB) - added by wpsmith 8 years ago.

Download all attachments as: .zip

Change History (5)

#1 @wpsmith
8 years ago

This probably goes without saying, but the changes therein belong to wp-admin/nav-menus.php

#2 @ocean90
8 years ago

  • Component changed from General to Menus

#3 @chriscct7
5 years ago

  • Focuses administration added

#4 @DrewAPicture
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #18584.

Note: See TracTickets for help on using tickets.