WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#18539 closed defect (bug) (duplicate)

PNG image resizing bug

Reported by: rom92 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: General Keywords:
Focuses: Cc:

Description

Here is the original image:
http://dl.rom1v.com/images/debian-installer.png

If I upload it to a Wordpress blog, it resizes it to 300×300, and the resulting image is OK.

If instead, I upload this image:
http://dl.rom1v.com/images/debian-installer-optipng.png
(which is the original image optimized by optipng)
then the resulting 300×300 image has bad colors.

With other images optimized by optipng, I have not this problem in Wordpress, maybe a specific bug when there are only few colors (maybe the bug always happens, but it more visible when few colors)…

Attachments (2)

debian-installer.png (15.3 KB) - added by rom92 6 years ago.
debian-installer-optipng.png (7.5 KB) - added by rom92 6 years ago.

Download all attachments as: .zip

Change History (3)

#1 @scribu
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Yep, it's a problem with the GD Image library.

Closing as duplicate of #6821

Note: See TracTickets for help on using tickets.