WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#18540 closed defect (bug) (fixed)

No Longer Able to Upload Images

Reported by: dlongnecker@… Owned by: dlongnecker@…
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Upload Keywords: has-patch
Focuses: Cc:

Description

After August 17th, I am unable to upload pictures to posts. The file is created, but the size of the file is 0 bytes.

Using WordPress 3.3-aortic-dissection.

There have been no changes to the file permissions of the server/etc. I have tried uploading from different PC's, but am getting the same results.

Attachments (1)

18540.diff (10.9 KB) - added by kurtpayne 4 years ago.
Temporary patch while plupload bug report is pending

Download all attachments as: .zip

Change History (7)

comment:1 @dlongnecker@…4 years ago

  • Cc dlongnecker@… added

comment:2 @dlongnecker@…4 years ago

Just tested using Google Chrome, and it works. IE 8 on Windows and Safari (on Mac) do not work.

@kurtpayne4 years ago

Temporary patch while plupload bug report is pending

comment:3 @kurtpayne4 years ago

  • Cc kpayne@… added
  • Component changed from General to Upload
  • Keywords has-patch dev-feedback added

Confirmed. This looks like a bug in the jsonSerialize() function in the plupload.silverlight module. I've submitted a bug report and a patch to the plupload github site, but I'm awaiting confirmation.

For reference plupload bug report

Please take a look at 18540.diff and see if this solves the problem for you. It's working on my dev site with IE8 and 3.3-aortic-dissection.

comment:4 follow-up: @ocean904 years ago

  • Keywords dev-feedback removed
  • Milestone changed from Awaiting Review to 3.3

I already mentioned the Silverlight bug in comment:ticket:18206:33.

The strange thing is, that it works on the demo page.

comment:5 in reply to: ↑ 4 @kurtpayne4 years ago

Replying to ocean90:

I already mentioned the Silverlight bug in comment:ticket:18206:33.

The strange thing is, that it works on the demo page.

Thanks for the link to #18206. It does shed some more light on the issue. It looks like there are two related issues. The plupload.silverlight jsonSerialize() function fails on any null value, it's not limited to WordPress.

In the WordPress plupload implementation, there's a null value being passed if the "scale images ..." checkbox is unchecked. This is perfectly valid. However, when combined with the silverlight runtime and the jsonSerialize() bug, it results in a javascript error.

comment:6 @azaozz4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

In [18620].

Note: See TracTickets for help on using tickets.