WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 16 months ago

#18542 closed defect (bug) (worksforme)

Error deleting users (single or bulk)

Reported by: drisley Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Users Keywords: reporter-feedback
Focuses: Cc:

Description

I'm not sure if this is something I'm overlooking, but I was having an issue deleting users on 3.2.1. The confirmation screen for deleting users kept looping, and no deletes were actually happening.

In looking at the source on wp-admin/users.php, it appears the form ACTION is missing on both forms (for single deletes and bulk). When I set the action to "users.php", it fixed the problem for me.

Change History (2)

comment:1 SergeyBiryukov3 years ago

  • Keywords reporter-feedback added; needs-patch removed

Can't reproduce neither in 3.2.1 nor in 3.3-trunk.

There's actually one form for both single and bulk deletions:
http://core.trac.wordpress.org/browser/tags/3.2.1/wp-admin/users.php#L157

Another one is for removing users from the site in Multisite:
http://core.trac.wordpress.org/browser/tags/3.2.1/wp-admin/users.php#L258

Both have action="", which is a valid representation of same-document reference, according to the URI specification (section 4.2 at http://www.ietf.org/rfc/rfc2396.txt).
However it's up to the browser to replace an empty URI reference with the base URI of the
current document when making a request.

comment:2 SergeyBiryukov16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.