WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18565 closed defect (bug) (duplicate)

Cannot move a post from Scheduled to Published.

Reported by: jorhett Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.2.1
Component: General Keywords: close
Focuses: Cc:

Description

It is impossible to move a post from Scheduled to Published.

Posts -> Edit - change Status to "Published" and Save -- nope, still Scheduled
Posts -> Quick Edit - change Status to "Published" and Save -- nope, still Scheduled

Posts -> Edit change Scheduled Time to less than one hour in the future -- doesn't publish
Posts -> Edit change Scheduled Time to more than an hour in the future -- posts on time.

This is repeatable on vanilla instances of WordPress 3.2.1 with no plugins.

The *ONLY* functional way to take a schedule post and make it Published right now is cut/paste to a new post.

Change History (12)

comment:1 dd323 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The *ONLY* functional way to take a schedule post and make it Published right now is cut/paste to a new post.

Setting it to a date in the future will always schedule it, Setting it to a date which has passed (an hour ago for example) should cause it to be published *now*. It is a UX issue however, and there's an existing ticket: #8368

comment:2 jorhett3 years ago

I'm sorry, but I disagree with your diagnosis.

  1. It doesn't appear to be a duplicate of 8368. In fact, the behavior described in 8368 is not replicable with 3.2.1. I cannot edit the time and hit cancel and get it to revert to published immediately. None of those steps work.
  1. Setting the scheduled time to the past does not publish it.
  1. Setting the scheduled time to a few minutes in the future does not publish it on time. You must set it forward several hours, at which point it publishes at that time.

comment:3 jorhett3 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:4 dd323 years ago

I cannot edit the time and hit cancel and get it to revert to published immediately. None of those steps work.

Perhaps try without any Plugins active then, As it works for me. (Schedule for +1 month, sets as scheduled, Edit it, Set it for -1month, update post, Post is published).

comment:5 jorhett3 years ago

dd32: go back and re-read. I replicated this on a vanilla install with no plugins.

comment:6 dd323 years ago

I replicated this on a vanilla install with no plugins.

My apologies, I didn't re-read the first post when replying to your comment. Still. I can't reproduce other than the before mentioned weird UX (Which is covered by a patch in #8368).

Last edited 3 years ago by dd32 (previous) (diff)

comment:7 SergeyBiryukov3 years ago

Posts -> Edit - change Status to "Published" and Save -- nope

Not sure about this step. There's no "Published" status for scheduled posts on Edit screen, only "Scheduled", "Pending Review" and "Draft".

Posts -> Quick Edit - change Status to "Published" and Save -- nope, still Scheduled
Posts -> Edit change Scheduled Time to less than one hour in the future -- doesn't publish

Confirmed as expected, since the date is still in the future.

Posts -> Edit change Scheduled Time to more than an hour in the future -- posts on time.

Can't reproduce this. But there's an UI glitch in this case regarding "Schedule for"/"Published on" text mentioned by garyc40 and addressed by his patch: ticket:8368:8.

The only way to "unschedule" a post with current UI is to set post time in the past.

Setting the scheduled time to the past does not publish it.

It should (and does so on my clean install).

#16068 contains another explanation of the UI issue, though it was closed as a duplicate of #8368.

comment:8 jorhett3 years ago

When I say scheduled for a few minutes in the future, I mean waiting those few minutes. It does not post on time. I have not figured out what the exact criteria are, but up to 10 minutes in the future does NOT post whereas an hour or more in the future does post on time.

I own the server and have root, so I can confirm that server time and website time are the same.

Re:The only way to "unschedule" a post with current UI is to set post time in the past.

Then the UI needs to indicate this. As I can easily open Quick Edit and change the status to Published, I would expect that this would take effect. It does not.

comment:9 jorhett3 years ago

Okay, I have found part of the problem: Wordpress was one hour behind. Apparently there are no daylight saving time adjustments? Which is weird because I find patches to trunk to deal with this in version 2.x, but missing in 3.x?

So it appears I simply didn't put them far enough in the past, and explains why anything I put less than an hour in the future didn't post while I was waiting.

comment:10 follow-up: jorhett3 years ago

So this bug is now about the fact that you can Quick Edit a post and change it from Scheduled to Published, but nothing occurs.

I would also suggest that something displaying the current time would be very helpful to authors when trying to determine why their posts are not publishing. Just at the top of the Posts page or something like that.

comment:11 technosailor3 years ago

  • Keywords close added
  • Resolution set to duplicate
  • Status changed from reopened to closed

There are indeed DST settings in WordPress as well as the traditional GMT +/- settings. Take a look in the dropdown. Timezones (such as America/New York) are there. When using these settings instead of the GMT +/- settings, then DST is respected.

The other problems you describe are, as noted by dd32, in #8368 as a UI issue.

comment:12 in reply to: ↑ 10 SergeyBiryukov3 years ago

Replying to jorhett:

So this bug is now about the fact that you can Quick Edit a post and change it from Scheduled to Published, but nothing occurs.

I've left a comment about that in #8368.

Note: See TracTickets for help on using tickets.