WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18572 closed defect (bug) (invalid)

Adding new link category fails with no error message.

Reported by: ghostseeker Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: General Keywords:
Focuses: Cc:

Description

  1. Go to link categories
  2. Enter a name
  3. Enter a slug
  4. Click Add New Category

OBSERVE: NOTHING HAPPENS.

Change History (8)

comment:1 ghostseeker3 years ago

Browser: IE9 (32 bit)
Operating system: Windows 7 (64 bit)

comment:2 SergeyBiryukov3 years ago

  • Keywords reporter-feedback added; needs-patch removed
  • Severity changed from major to normal

Can't reproduce. Tested in IE 9 and Firefox 7. Sounds like a JavaScript conflict with a plugin or theme.

comment:3 ghostseeker3 years ago

I just tested this issue with ALL plugins DEACTIVATED and using the Twenty Eleven theme.
The category is added to the WP_terms table, but the term_ID and term_order are set to NULL. Shouldn't at least the term_ID have a value other than NULL?

Paul

comment:4 ghostseeker3 years ago

  • Keywords 2nd-opinion dev-feedback added

comment:5 tillkruess3 years ago

Works fine for me at 18714 and in 3.2.1.

comment:6 ghostseeker3 years ago

  • Keywords close added
  • Resolution set to invalid
  • Status changed from new to closed

Please close this ticket. I found the culprit. During the move to a new domain, the term_ID table in the db had gotten mangled, which removed the indexes, and removed properties of key fields. My appologies for 'bugging' you guys on this...;-) Paul

comment:7 dd323 years ago

  • Milestone Awaiting Review deleted

comment:8 ocean903 years ago

  • Keywords reporter-feedback 2nd-opinion dev-feedback close removed
Note: See TracTickets for help on using tickets.