WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

#18595 closed defect (bug) (duplicate)

Undefined index in WP_Widget_Search

Reported by: SergeyBiryukov Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.3
Component: Widgets Keywords: has-patch
Focuses: Cc:

Description

While switching themes and moving around widgets for #17979, at some point I noticed that adding a Search widget results in error on the frontend:

Notice: Undefined index: title in wp-includes/default-widgets.php on line 180

I can't reproduce the issue again, but Google shows thousands of results with this exact message.

Most of the default widgets already have empty() checks for title, so WP_Widget_Search and WP_Nav_Menu_Widget should have them too.

Attachments (2)

18595.patch (892 bytes) - added by SergeyBiryukov 8 years ago.
18595.2.patch (1.3 KB) - added by SergeyBiryukov 8 years ago.

Download all attachments as: .zip

Change History (3)

#1 @SergeyBiryukov
8 years ago

  • Milestone 3.3 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Another message found in Google:

Notice: Undefined index: filter in wp-includes/default-widgets.php on line 382

18595.2.patch could fix that too, but the ticket turned out to be a duplicate of #16761.

Note: See TracTickets for help on using tickets.