WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 10 months ago

#18617 closed defect (bug) (maybelater)

Renaming menus orphans children when using global terms

Reported by: adambackstrom Owned by:
Milestone: Priority: low
Severity: normal Version: 3.2.1
Component: Menus Keywords: close
Focuses: multisite Cc:

Description

Renaming a menu when global terms is enabled will cause the menu to be disassociated from its children. This is caused by the reliance on wp_get_nav_menu_object() in wp_update_nav_menu_item() and elsewhere, where the calling function attempts to get the menu object using the old global term id rather than the new global term id. The menu items appear to be invalid because the menu term id has changed.

Change History (3)

#1 @nacin
4 years ago

  • Focuses multisite added
  • Milestone changed from Awaiting Review to Future Release
  • Priority changed from normal to low

Sorry you never got a reply, Adam. Basically no one uses global terms, at least not on purpose. I think it'd be nice to fix this but it's a pretty low priority.

#2 @chriscct7
2 years ago

  • Keywords close added

#3 @swissspidy
10 months ago

  • Milestone Future Release deleted
  • Resolution set to maybelater
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.