WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#18634 closed feature request (duplicate)

Foreign characters in filenames

Reported by: vilhjalmurv Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: Media Keywords: needs-patch
Focuses: Cc:

Description

Not sure if this is a feature request or a bug, and if this has been reported before (I wasn't able to find it at least).

When users upload a file that has foreign characters in the filename the link to that file will not work. I'm Icelandic and this happens to me fairly often, and I don't wan't to have to worry about whether the person uploading has changed the filename properly or not.

This happens to me specially with Icelandic letters, like ð, þ, é, á, and others like that.

I have written a plugin that handles this for Icelandic letters, it maybe can be done better or in a simpler way, but since this works for me, I've been using it.

Attachments (1)

replace-icelandic.php (807 bytes) - added by vilhjalmurv 4 years ago.

Download all attachments as: .zip

Change History (4)

comment:1 follow-up: @SergeyBiryukov4 years ago

If that's on Windows, could be a duplicate of #15955.

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

comment:2 in reply to: ↑ 1 @vilhjalmurv4 years ago

Replying to SergeyBiryukov:

If that's on Windows, could be a duplicate of #15955.

This is on windows, so it might be...

comment:3 @SergeyBiryukov4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is specific to Windows builds of PHP (see my comment in #15955).

Not sure if there's a good solution until PHP supports working with Windows filenames in Unicode.

Note: See TracTickets for help on using tickets.