WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 2 years ago

#18643 closed defect (bug) (fixed)

Twenty Eleven incorrectly only uses .current_page_item for nav menu styling

Reported by: Viper007Bond Owned by: nacin
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

Twenty Eleven only highlights pages in its nav menu due to using CSS classes targeted at wp_page_menu() output. It works with custom nav menus because that functionality outputs backwards compatibility classes.

It should also highlight .current-menu-item and .current-menu-ancestor.

To reproduce, add some categories to your nav menu and then click on one of them. They won't be bolded as they should be.

Attachments (1)

18643.patch (474 bytes) - added by Viper007Bond 3 years ago.

Download all attachments as: .zip

Change History (4)

Viper007Bond3 years ago

comment:1 SergeyBiryukov3 years ago

  • Component changed from Themes to Bundled Theme
  • Milestone changed from Awaiting Review to 3.3

comment:2 nacin2 years ago

Running on WP.com, good enough for me.

comment:3 nacin2 years ago

  • Owner set to nacin
  • Resolution set to fixed
  • Status changed from new to closed

In [19301]:

Highlight current-menu-item and current-menu-ancestor in Twenty Eleven. props Viper007Bond, fixes #18643.

Note: See TracTickets for help on using tickets.