WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18656 closed defect (bug) (fixed)

Screen Options not working on Post Editor

Reported by: Ipstenu Owned by: azaozz
Milestone: 3.3 Priority: normal
Severity: major Version: 3.3
Component: Editor Keywords:
Focuses: Cc:

Description

I tested this with an svn on 18666

Installed a new WordPress install

Went to the Post Editor - formats are visible

Unchecked 'formats' from screen options. Everything works.

Checked 'Auto' for columns from screen options. Everything works. (nb: There was nothing auto-checked for columns)

Go back and check formats .... nothing shows up.

I get the same on my existing (multisite) install at ipstenu.org too, which is why I tested it locally. I'm using twentyeleven, no mods, no plugins, just a bog standard svn up.

Attachments (2)

18656.diff (406 bytes) - added by solarissmoke 3 years ago.
Remove !important declaration on .hide-if-js etc
18656.2.diff (576 bytes) - added by Ipstenu 3 years ago.
Modify the wp-admin.css file too.

Download all attachments as: .zip

Change History (12)

comment:1 @Ipstenu3 years ago

  • Summary changed from Post Form not honoring Screen Options to Post Formats not honoring Screen Options

comment:2 @Ipstenu3 years ago

Oh. Interesting. I can't add ANYTHING.

I can check anything I want from "Show on screen" but nothing shows on my screen. Once I uncheck a box and refresh, that's it. It's gone.

comment:3 @Ipstenu3 years ago

  • Summary changed from Post Formats not honoring Screen Options to Screen Options not working on Post Editor

comment:4 @solarissmoke3 years ago

The problem is caused by [18664]. The !important declaration on .hide-if-js is overriding the inline style set by jQuery.show(), which means the meta box doesn't appear when you check the option. Oops.

Think we have to revert that change.

@solarissmoke3 years ago

Remove !important declaration on .hide-if-js etc

comment:5 follow-up: @azaozz3 years ago

Perhaps we need to use another class when loading hidden postboxes and leave .js .hide-if-js only for stuff we don't want to ever show when js is enabled. Thinking it's handy to be able to do that. Same for .no-js .hide-if-no-js.

comment:6 @Ipstenu3 years ago

The box stays unchecked too (svn r18667). solarissmoke's diff does not correct that.

ETA - That would be because the wp-admin.css file has to be changed too. If you change 'em both, you're fine. Elf drink coffee, THEN comment.

Last edited 3 years ago by Ipstenu (previous) (diff)

@Ipstenu3 years ago

Modify the wp-admin.css file too.

comment:7 in reply to: ↑ 5 ; follow-up: @nacin3 years ago

Replying to azaozz:

Perhaps we need to use another class when loading hidden postboxes and leave .js .hide-if-js only for stuff we don't want to ever show when js is enabled. Thinking it's handy to be able to do that. Same for .no-js .hide-if-no-js.

Unfortunately a plugin may be leveraging a similar technique, and the changeset may break things. hide-if-js seems to be simply hide me if there is JS, and hide-if-no-js means the same thing. Doesn't make it permanent.

comment:8 @azaozz3 years ago

  • Owner set to azaozz
  • Resolution set to fixed
  • Status changed from new to closed

In [18668]:

Revert [18664] and handle any similar cases separately, props SergeyBiryukov, fixes #16810, fixes #18656

comment:9 in reply to: ↑ 7 @azaozz3 years ago

Replying to nacin:

Agreed, this also confirms that !important shouldn't be used anywhere :)

comment:10 @azaozz3 years ago

  • Milestone changed from Awaiting Review to 3.3
Note: See TracTickets for help on using tickets.