WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18659 closed defect (bug) (duplicate)

editors should not have to enter military time for posts

Reported by: _ck_ Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

WordPress is over eight years old now and has added megabytes of code to the editor section in an attempt to make it more user friendly.

Yet post times still have to be entered/changed as military time which 99% of the world population do not use.

A simple am/pm toggle and adjusting for that during saving is long overdue.

Change History (5)

comment:1 scribu3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Going to close as duplicate of #7665

The proposed solutions are different, but the problem is the same.

comment:2 nacin3 years ago

For what it's worth, _ck_, 24-hour time is the dominant time notation used around the world, pretty much except for North America and some other English-speaking countries, where we largely call it "military time" since most common folk here cannot possibly grasp concepts like the metric system or counting to 24.

Two-thirds of our users are international.

I make note of these things because the tone of some of your recent tickets aren't necessary. You don't need to make your case with hyperbole, unnecessary statements like "megabytes of code," or comments as to how old WordPress is.

comment:3 follow-up: _ck_3 years ago

I think perspective is critical which is why I add it to my tickets. I've earned the right to say it by having to support people using WP for all these years, since WP 1.5 when Matt had zero employees.

Perspective is also important if you can consider novice users sit down and edit a post in WordPress and want to change the time, I assure you, the lack of am/pm is important, because they will set 4am instead of 4pm every time.

But by all means, keep throwing in more jquery, and keep re-designing the admin area over and over adding even more code and queries. You'll get it eventually in maybe another eight years.

comment:4 in reply to: ↑ 3 ; follow-up: GaryJ3 years ago

Replying to _ck_:

I think perspective is critical which is why I add it to my tickets. I've earned the right to say it by having to support people using WP for all these years, since WP 1.5 when Matt had zero employees.

Perspective adds nothing. Anyone who has used WP for a day has as much right to post a Trac ticket for something they believe is wrong, as much as the core guys themselves.

Your bug report has three sentences - the first gives potential facts unrelated to the bug, the second gives the crux of your trac report albeit without an explanation of "miltary time" (which, it isn't by the way, since that would also have no hour-minute separator) and a made-up statistic, while your final sentence adds one possible suggestion and an opinion.

If you want to be taken seriously, look-up and link to all the per-country government websites that show what their national standard of displaying time is and note in the summary which follow ISO8601 (or similar variations thereof) and which maintain an AM/PM system. Things are standard for a reason - they reduce ambiguity.

comment:5 in reply to: ↑ 4 _ck_3 years ago

Replying to GaryJ:

Not sure how to respond to someone who doesn't think deep experience with a product matters, let alone from practically day one and having written dozens of plugins for it - so I am going to leave it here. I cannot possibly deal with all the wordpress apologists.

Given enough time you'll eventually be in my shoes and then you'll finally understand the frustration.

Note: See TracTickets for help on using tickets.