WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18670 closed defect (bug) (fixed)

"Add new link" submit button missing

Reported by: loony636 Owned by:
Milestone: 3.3 Priority: normal
Severity: normal Version: 3.3
Component: Administration Keywords:
Focuses: Cc:

Description

The issue is as described here, but is present using the latest nightly build: http://wordpress.org/support/topic/save-button-missing-to-add-new-link

Change History (14)

comment:1 solarissmoke3 years ago

  • Keywords reporter-feedback added

Can't reproduce in r18674, there is a submit button for me at the bottom of the "add new link category" section. Can you confirm that it happens on a clean install with no plugins?

comment:2 follow-ups: ocean903 years ago

  • Component changed from General to Administration
  • Keywords needs-patch added; reporter-feedback removed
  • Milestone changed from Awaiting Review to 3.3

Nice catch.

If you switch to 1 coloum the box is gone.

comment:3 loony6363 years ago

  • Owner set to loony636
  • Status changed from new to accepted

I've tried switching the number of columns in the screen options and I cannot coax it into existence. I did a clean install and the issue is still there.

comment:4 loony6363 years ago

  • Owner loony636 deleted
  • Status changed from accepted to assigned

And I did not want to own this ticket. Really noobed it up here.

comment:5 in reply to: ↑ 2 Ipstenu3 years ago

Replying to ocean90:

Nice catch.

If you switch to 1 coloum the box is gone.

Which is 'worse' because it default starts to 1 column on revision 18682

And ... it looks like columns are only changing 'right' on the Dashboard which is another issue. #18678 created for that.

comment:6 in reply to: ↑ 2 loony6363 years ago

Replying to ocean90:

Nice catch.

If you switch to 1 coloum the box is gone.

There seems to be a deeper mystery; I can switch to 'auto' to make the box appear on a desktop computer, but I cannot for the life of me get it to appear on any of my laptops. Can someone confirm this?

And on a side note, it doesn't work on my iPhone either, which I'm sure we were all waiting to hear.

comment:7 Ipstenu3 years ago

I think it's related to the columns/metaboxes issue.

But it doesn't show up on my laptop either. No desktop to test on.

comment:8 follow-up: dd323 years ago

What browsers (and operating systems) are you seeing the problem on?

comment:9 in reply to: ↑ 8 loony6363 years ago

Replying to dd32:

What browsers (and operating systems) are you seeing the problem on?

I'm getting it across the board; on every browser and operating system (both Mac and Windows) I have access to. The only difference seems to be between laptops and desktops, for reasons I can't yet fathom.

comment:10 follow-up: dd323 years ago

Ah, yes I see it now.

It appears to depend on if you've previously re-arranged items on the page or not.

right now, by default, it displays in 1 column - However, it only displays the items from the first column, If you select any of the other layout options (1 col, 2, or auto) it'll re-arrange all of the widgets properly.

See #18198 for the Work-in-progress of the responsive admin (which is what you're seeing)

comment:11 in reply to: ↑ 10 loony6363 years ago

Replying to dd32:

Ah, yes I see it now.

It appears to depend on if you've previously re-arranged items on the page or not.

right now, by default, it displays in 1 column - However, it only displays the items from the first column, If you select any of the other layout options (1 col, 2, or auto) it'll re-arrange all of the widgets properly.

See #18198 for the Work-in-progress of the responsive admin (which is what you're seeing)

I've tried toggling the different layout options, but this only seems to solve the problem on my desktop; on my laptop both the 1 and 2 column options, and the box fails to appear. 'Auto' shifts the boxes over as though to allow for the second column, but it fails to materialise.

I've tried it on literally three different computers, and done a clean install.

comment:12 dd323 years ago

but it fails to materialise.

I missed it the first few times, It inserts itself half way down the page, in position 4 of 8 for me. That should be off the bottom of the screen on most laptops when you're at the top (and off the top of the page when you're at the bottom). It's not the best place for it to show up in 1 column mode!

comment:13 Ipstenu3 years ago

FYI, this is working now. I think this can be switched to 'fixed' per changes in #18198

comment:14 ocean903 years ago

  • Keywords needs-patch removed
  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.