WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 14 months ago

Last modified 14 months ago

#18679 closed defect (bug) (duplicate)

Images added via SSL admin backend are included via https in the frontend

Reported by: multimule Owned by:
Milestone: Priority: normal
Severity: major Version: 3.2.1
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

When logged in to the admin interface via a secure connection (SSL / HTTPS), images that are being added to an article will reference the image URL with https:// as opposed to http://

This behaviour is inconsistent as the method the admin interface is access shall be independent of the frontend output.

It also can break output in case of using self-signed SSL certificates. In that case a client may display the blog correctly, but without any images (or error icons for the images).

Change History (7)

comment:1 @multimule4 years ago

  • Summary changed from Images added via SSL admin backend will are included via https in the frontend to Images added via SSL admin backend are included via https in the frontend

comment:2 @johnbillion4 years ago

  • Cc johnbillion@… added

comment:3 @dd324 years ago

Can you reproduce this using a Default theme(TwentyTen or TwentyEleven)?

The link to the image should be dynamically generated when the image is retrieved, the only field that isn't dynamic, is the Guid field, which should never be used as a url to the image (despite the fact that it appears as such).. So it'd be appreciated if you can check to see if it occurs with a "known good" theme (aka, the default themes)

comment:4 @SergeyBiryukov4 years ago

  • Keywords reporter-feedback added

comment:5 @marfarma4 years ago

Related to 15928#comment:5 -- multimule's reported behavior is seen when #15928 is worked-around with a filter on get_option('siteurl').

See 19023#comment:5 for an expanded explanation and related discussion.

Last edited 4 years ago by SergeyBiryukov (previous) (diff)

comment:6 @ericlewis14 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15928.

comment:7 @DrewAPicture14 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.