WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 5 months ago

#18681 closed defect (bug) (duplicate)

XMLRPC wp.getPageList and auto-draft pages broken dates

Reported by: skithund Owned by:
Milestone: Priority: normal
Severity: major Version: 3.2.1
Component: XML-RPC Keywords: has-patch dev-feedback
Focuses: Cc:

Description

XMLRPC wp.getPageList method returns all pages, including auto-draft ones.

auto-draft pages have post_date_gmt date as '0000-00-00 00:00:00', resulting in invalid dates in XMLRPC reply.

<name>date_created_gmt</name>
<value><dateTime.iso8601>-0001113TT0::0::00</dateTime.iso8601></value>

Remove auto-drafts from wp.getPageList method or fix post_date_gmt somehow.

Attachments (1)

xmlrpc.diff (383 bytes) - added by skithund 3 years ago.
Patch against current 3.2 branch for removing auto-drafts from listing

Download all attachments as: .zip

Change History (4)

skithund3 years ago

Patch against current 3.2 branch for removing auto-drafts from listing

comment:1 SergeyBiryukov3 years ago

  • Keywords has-patch added

comment:2 c3mdigital11 months ago

  • Keywords dev-feedback added

comment:3 markoheijnen5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closed this as duplicate of #19733. That fixed the date issue in 3.4

Note: See TracTickets for help on using tickets.