Make WordPress Core

Opened 13 years ago

Closed 10 years ago

#18684 closed enhancement (wontfix)

XMLRPC metaWeblog.newMediaObject doesn't have possibility for setting excerpt/content

Reported by: skithund's profile skithund Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.2.1
Component: XML-RPC Keywords: has-patch
Focuses: Cc:

Description

XMLRPC metaWeblog.newMediaObject method only sets empty content for attachment and doesn't have possibility for setting excerpt and/or content for attachments.

Attachments (2)

newmediaobject.diff (836 bytes) - added by skithund 13 years ago.
Add possibility for setting post_excerpt and post_content
xmlrpc.diff (876 bytes) - added by josephscott 12 years ago.

Download all attachments as: .zip

Change History (7)

@skithund
13 years ago

Add possibility for setting post_excerpt and post_content

#1 @josephscott
12 years ago

  • Cc josephscott added

@josephscott
12 years ago

#2 @josephscott
12 years ago

  • Keywords dev-feedback added

I've uploaded a diff that uses 'content' and 'description' for the field names. Those are the labels WP shows in wp-admin and those are the field names that wp.getMediaItem uses to expose the same data.

I'd like to get some extra review on this though. We want to make sure these fields can't be used to inject bad things by people how shouldn't be able to do that sort of thing.

#3 @nacin
12 years ago

  • Keywords dev-feedback removed

Looks good.

#4 @nacin
12 years ago

Should we be adding more things to non-WP methods? In that case, duplicate of #5461?

#5 @markoheijnen
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

#5461 got closed for WP method, so closing this one too.

Note: See TracTickets for help on using tickets.