Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#18699 closed defect (bug) (duplicate)

admin_head-(plugin_page) with "noheader"

Reported by: shauno Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.2.1
Component: Plugins Keywords:
Focuses: Cc:


I'm busy writing a plugin, and came across the following behaviour:
As per codex page http://codex.wordpress.org/Plugin_API/Action_Reference/admin_head-%28plugin_page%29 you can hook into the page <head> tag for your plugin page.

If the plugin submits to itself, with the GET variable noheader, and then manually includes wp-admin/admin-header.php, the hook doesn't appear to run.

I can't seem to find any official documentation on noheader, but the method I am using is described all over the internet.

I will try attach a short plugin that demonstrates the issue. Found here too: http://pastebin.com/GaUZ6jRp

(I did post this in the forums a few days ago, but got nothing)

Attachments (1)

noheader-test.php (1.0 KB) - added by shauno 6 years ago.
Short plugin demo'ing the issue described

Download all attachments as: .zip

Change History (4)

6 years ago

Short plugin demo'ing the issue described

#1 @dd32
6 years ago

This should be fixed by #16143 - Can you try under trunk?

#2 @dd32
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Works for me under trunk, so closing as a duplicate of #16143

#3 @shauno
6 years ago

Cool, works under trunk for me too.

Note: See TracTickets for help on using tickets.