WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#18720 closed enhancement (duplicate)

When switching themes assign a default nav menu to theme location

Reported by: dgwyer Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.2.1
Component: Menus Keywords:
Focuses: Cc:

Description

It is pretty common these days for themes to use custom nav menus. If a lot of pages have been published that haven't been organized into parent/sub-pages then the wp_nav_menu fallback rendering can look pretty hideous when switching themes.

This is because the fallback menu function ALWAYS seems to be invoked (whether any theme locations/nav menus exist or not).

It would be better when switching themes to assign default nav menus to theme locations. If no theme locations and/or nav menus exist then use the fallback menu function as currently implemented.

Change History (3)

#1 @ocean90
7 years ago

Duplicate of #18588?

#2 @dgwyer
7 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Looks like it.

Didn't see that one when I searched before posting!

#3 @ocean90
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.