WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18735 closed defect (bug) (duplicate)

Subcategory archive does work with any name as parent category in URL

Reported by: ocean90 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.1
Component: Canonical Keywords:
Focuses: Cc:

Description

Parent category is parentcategory and his sub category is subcategory.

The URL will be domain.com/category/parentcategory/subcategory.

The problem is, that you will get the same page if you use any words as parentcategory.

Examples:

  • domain.com/category/xxx/subcategory
  • domain.com/category/subcategory
  • domain.com/category/foo/bar/subcategory

IMO redirect_canonical should do his work here (and sometimes it does).

In 3.1 it does redirect.
In 3.1.4 it doesn't redirect; after r17549.
In 3.2.1 it doesn't redirect.
Duck_ found that it does redirect before r18079.
In current trunk it doesn't redirect.

Change History (1)

comment:1 ocean903 years ago

  • Keywords dev-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

#18734

It wasn't me!

Note: See TracTickets for help on using tickets.