WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#18741 closed defect (bug) (fixed)

Autoupdate does not install translation files

Reported by: sirzooro Owned by: dd32
Milestone: 3.2.2 Priority: normal
Severity: normal Version: 3.2.1
Component: Upgrade/Install Keywords: has-patch
Focuses: Cc:

Description

WP autoupdater does not install translation files - at least when I tried to convert my english WP install to Polish.

Steps to reproduce:

  • install WP (English version);
  • add define('WPLANG', 'pl_PL'); to wp-config.php;
  • open /wp-admin/update-core.php page and install WordPress with pl_PL translations.

For some reason updater does not create wp-content/languages directory and does not copy translation files.

As I recall, this worked in the past (for sure on some last WP 2.x versions), but cannot tell when it stopped working.

Attachments (1)

18741.patch (810 bytes) - added by SergeyBiryukov 3 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 dd323 years ago

What file does it say it's installing on the upgrade/re-install process page?

comment:2 dd323 years ago

  • Keywords reporter-feedback added

And by file, I mean't this zip file:

Downloading update from http://downloads.wordpress.org/…

comment:3 SergeyBiryukov3 years ago

Confirmed with ru_RU as well.

Downloading update from http://ru.wordpress.org/wordpress-3.2.1-ru_RU.zip…

comment:4 sirzooro3 years ago

  • Keywords reporter-feedback removed

Message for pl_PL is similar:

Downloading update from http://pl.wordpress.org/wordpress-3.2.1-pl_PL.zip…

Last edited 3 years ago by sirzooro (previous) (diff)

comment:5 dd323 years ago

  • Owner set to dd32
  • Status changed from new to accepted

Cheers, I'll take a look under the hood tomorrow and see what's going on. I have a feeling this might be caused by the locale_package variable not being set when you install the way you have.

SergeyBiryukov3 years ago

comment:6 SergeyBiryukov3 years ago

  • Keywords has-patch added; needs-patch removed
  • Milestone changed from Awaiting Review to 3.3

In [17576], str_replace() had arguments in the wrong order.

comment:7 nacin3 years ago

  • Milestone changed from 3.3 to 3.2.2

comment:8 dd323 years ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In [18764]:

Fix typo in languages directory creation for new installations. Props SergeyBiryukov. Fixes #18741 for 3.2

comment:9 dd323 years ago

In [18765]:

Fix typo in languages directory creation for new installations. Props SergeyBiryukov. Fixes #18741 for trunk

comment:10 dd323 years ago

For anyone who comes across this bug, create your wp-content/languages/ folder manually, and then perform the update, the language files will be loaded then.

#18784 was closed as a duplicate.

Note: See TracTickets for help on using tickets.